summaryrefslogtreecommitdiff
path: root/infrastructure/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2018-02-25 08:18:34 +0000
committerChris Wilson <chris+github@qwirx.com>2018-02-25 08:18:34 +0000
commitbc48bec97b65534966da74a07ed3edb3f13f6263 (patch)
tree387b7b54d15fa2f646366a51ada52034ea26fa6f /infrastructure/cmake/CMakeLists.txt
parent6d7e9562e8485591a4888f1fc2d3c6c657dc7a01 (diff)
Revert "Add support for OpenSSL 1.1 and replace deprecated function calls"
Until shown to be safe. See message from Johann Glaser to the mailing list. This reverts commit 85e7efc3fa0477f60318d2cd2144503a9ea8feb9.
Diffstat (limited to 'infrastructure/cmake/CMakeLists.txt')
-rw-r--r--infrastructure/cmake/CMakeLists.txt21
1 files changed, 1 insertions, 20 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index 65f59eb8..25015452 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -407,26 +407,7 @@ else()
endif()
# Link to OpenSSL
-# Workaround for incorrect library suffixes searched by FindOpenSSL:
-# https://gitlab.kitware.com/cmake/cmake/issues/17604
-if(WIN32 AND MSVC)
- find_package(OpenSSL)
- set(OPENSSL_SSL_LIBRARY ${SSL_EAY_RELEASE})
- set(OPENSSL_CRYPTO_LIBRARY ${LIB_EAY_RELEASE})
- set(OPENSSL_LIBRARIES ${OPENSSL_SSL_LIBRARY} ${OPENSSL_CRYPTO_LIBRARY} crypt32)
- find_package_handle_standard_args(OpenSSL
- REQUIRED_VARS
- OPENSSL_SSL_LIBRARY
- OPENSSL_CRYPTO_LIBRARY
- OPENSSL_INCLUDE_DIR
- VERSION_VAR
- OPENSSL_VERSION
- FAIL_MESSAGE
- "Could NOT find OpenSSL, try to set the path to OpenSSL root folder in the system variable OPENSSL_ROOT_DIR"
- )
-else()
- find_package(OpenSSL REQUIRED)
-endif()
+find_package(OpenSSL REQUIRED)
include_directories(${OPENSSL_INCLUDE_DIR})
target_link_libraries(lib_crypto PUBLIC ${OPENSSL_LIBRARIES})