summaryrefslogtreecommitdiff
path: root/infrastructure/cmake
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2017-09-18 06:09:25 +0100
committerChris Wilson <chris+github@qwirx.com>2017-09-18 06:10:07 +0100
commitb7c6a133b8868223bc39084968e0cac332fd4dfe (patch)
treefff38e59f0d7ea41915ec18f245e3b6b6ed573df /infrastructure/cmake
parent69e19233045b484b2378e3568bc7dd711d104122 (diff)
Install Box Backup in a temporary directory in Windows unibuilds
Otherwise the unibuild fails at the end for non-administrator users when it tries to write to C:\Program Files\BoxBackup.
Diffstat (limited to 'infrastructure/cmake')
-rw-r--r--infrastructure/cmake/windows/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/infrastructure/cmake/windows/CMakeLists.txt b/infrastructure/cmake/windows/CMakeLists.txt
index 1c88472e..80d1369b 100644
--- a/infrastructure/cmake/windows/CMakeLists.txt
+++ b/infrastructure/cmake/windows/CMakeLists.txt
@@ -100,9 +100,9 @@ ExternalProject_Add(boost
URL "http://downloads.sourceforge.net/project/boost/boost/${BOOST_VERSION}/boost_${BOOST_VERSION_UNDERSCORES}.tar.bz2"
URL_HASH ${BOOST_HASH}
# DOWNLOAD_NO_PROGRESS 1
- CONFIGURE_COMMAND "" # none needed
- BUILD_COMMAND ${CMAKE_COMMAND} -E echo "No build step needed" # none needed
- INSTALL_COMMAND "" # none needed
+ CONFIGURE_COMMAND ${CMAKE_COMMAND} -E echo "No configure step needed"
+ BUILD_COMMAND ${CMAKE_COMMAND} -E echo "No build step needed"
+ INSTALL_COMMAND ${CMAKE_COMMAND} -E echo "No install step needed"
)
if(BOXBACKUP_VERSION)
@@ -119,6 +119,7 @@ ExternalProject_Add(boxbackup
-DPCRE_ROOT=${install_dir}
-DBOOST_ROOT=${CMAKE_BINARY_DIR}/Source/boost
-DBOX_SUPPORT_READLINE=OFF
+ -DCMAKE_INSTALL_PREFIX=${install_dir}
-DAPPVEYOR_MODE=1
-DDEBUG=${DEBUG}
${boxbackup_cmake_args}