summaryrefslogtreecommitdiff
path: root/infrastructure/cmake
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2015-12-19 00:43:08 +0000
committerChris Wilson <chris+github@qwirx.com>2015-12-19 23:55:31 +0000
commitc17c6d6aafe04a5fde4252f52e5af7af14d99862 (patch)
tree6abe3577419662ed024799834dac951aab5e7add /infrastructure/cmake
parentdbd29ff4a11b517cfe861dfc97d944cd631cb8cd (diff)
Fix PERL_EXECUTABLE #define to use properly-escaped path
Diffstat (limited to 'infrastructure/cmake')
-rw-r--r--infrastructure/cmake/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index 5f7bd608..7c996dff 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -280,5 +280,6 @@ find_library(pcred_lib_path pcred ${base_dir}/../pcre-win32/lib)
target_link_libraries(lib_common PUBLIC "${pcreposixd_lib_path}" "${pcred_lib_path}")
# Define the location of the Perl executable, needed by testbackupstorefix
-cmake_to_native_path(PERL_EXECUTABLE perl_executable_native)
-target_compile_definitions(test_backupstorefix PRIVATE -DPERL_EXECUTABLE="${perl_executable_native}")
+cmake_to_native_path("${PERL_EXECUTABLE}" perl_executable_native)
+string(REPLACE "\\" "\\\\" perl_path_escaped ${perl_executable_native})
+target_compile_definitions(test_backupstorefix PRIVATE -DPERL_EXECUTABLE="${perl_path_escaped}")