summaryrefslogtreecommitdiff
path: root/infrastructure/cmake
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2015-12-27 10:58:38 +0000
committerChris Wilson <chris+github@qwirx.com>2015-12-27 10:58:38 +0000
commit130b85588efdf3221130c098c1e7c8898c55ea00 (patch)
tree147de22a2ed22111bca92a229a55dcbc86b57f7f /infrastructure/cmake
parent2e7371e4ed98d6a5e0a7c0845cf9f50a98f055a7 (diff)
Fix passing of "release" argument to runtest.pl in release mode.
Diffstat (limited to 'infrastructure/cmake')
-rw-r--r--infrastructure/cmake/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index 47d30bc5..6dedf429 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -200,7 +200,7 @@ foreach(module_dep
"${module_path}/_main.cpp")
add_test(NAME ${test_name}
COMMAND ${PERL_EXECUTABLE} ${base_dir}/runtest.pl.in ${test_name}
- ${CMAKE_BUILD_TYPE})
+ $<CONFIG>)
elseif(module_name MATCHES "^(lib_.*|qdbm)$")
if(DEBUG)
message(STATUS "add library '${module_name}': '${module_files}'")