summaryrefslogtreecommitdiff
path: root/infrastructure/cmake
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2015-12-24 18:08:40 +0000
committerChris Wilson <chris+github@qwirx.com>2015-12-24 18:08:40 +0000
commitd13cb62d1f893e015ad8967c30db0d439aad83a7 (patch)
tree7e6d7c645bd89eee52851f54c2c1caef509d23d0 /infrastructure/cmake
parentc0b94d0d7c9cb16777c72cf7789b206da0e2f05d (diff)
In release configuration, install binaries into release tree, not debug tree.
Diffstat (limited to 'infrastructure/cmake')
-rw-r--r--infrastructure/cmake/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index ad387347..79551168 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -209,8 +209,13 @@ foreach(module_dep
# We need to install binaries in specific places so that test
# runner can find them:
install(FILES "$<TARGET_FILE:${module_name}>"
+ CONFIGURATIONS Debug
DESTINATION "${base_dir}/debug/${module_dir}"
RENAME "${bin_name}${CMAKE_EXECUTABLE_SUFFIX}")
+ install(FILES "$<TARGET_FILE:${module_name}>"
+ CONFIGURATIONS Release
+ DESTINATION "${base_dir}/release/${module_dir}"
+ RENAME "${bin_name}${CMAKE_EXECUTABLE_SUFFIX}")
endif()
target_compile_definitions(${module_name} PRIVATE -DBOX_MODULE="${module_name}")