summaryrefslogtreecommitdiff
path: root/infrastructure/mingw
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2016-09-10 20:54:50 +0100
committerChris Wilson <chris+github@qwirx.com>2016-09-10 20:54:50 +0100
commit2f1ddd1ee99f63ce05e3b3573e9a4dbdbbb02436 (patch)
treedb40d103ecc2a75d80e33380bcfbcbac29ceb6da /infrastructure/mingw
parent26ecf3418e7f0e040b6cd577ea14f56edb55eeae (diff)
Remove old hard-coded MSVC and MinGW configs.
Should be replaced by CMake now.
Diffstat (limited to 'infrastructure/mingw')
-rwxr-xr-xinfrastructure/mingw/compile-boxbackup-cygwin.sh57
-rwxr-xr-xinfrastructure/mingw/configure.sh45
-rw-r--r--infrastructure/mingw/environment.sh11
-rwxr-xr-xinfrastructure/mingw/runtest.sh7
4 files changed, 0 insertions, 120 deletions
diff --git a/infrastructure/mingw/compile-boxbackup-cygwin.sh b/infrastructure/mingw/compile-boxbackup-cygwin.sh
deleted file mode 100755
index 02b05852..00000000
--- a/infrastructure/mingw/compile-boxbackup-cygwin.sh
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/bin/sh
-
-set -e
-set -x
-
-basedir=`cd $(dirname $0)/../../.. && pwd`
-cd $basedir
-
-wget -c https://cygwin.com/setup-x86_64.exe \
-|| powershell wget https://cygwin.com/setup-x86_64.exe -UseBasicParsing -outfile setup-x86_64.exe
-
-chmod a+x setup-x86_64.exe
-./setup-x86_64.exe --quiet-mode --packages \
- "autoconf,automake,gdb,make,mingw64-x86_64-gcc,mingw64-x86_64-gcc-g++,
- ,mingw64-x86_64-zlib,libxml2,libxslt,perl,subversion,unzip,vim,wget"
-
-install_prefix=/usr/x86_64-w64-mingw32
-compiler_prefix=x86_64-w64-mingw32
-
-openssl_source=https://www.openssl.org/source/
-latest_openssl=`wget -O- -q $openssl_source \
-| grep '<td><a href="openssl-1.0.*.tar.gz">' \
-| sed -e 's/.tar.gz">.*//' -e 's/.*"//' | sort | tail -1`
-
-wget -c $openssl_source/$latest_openssl.tar.gz
-tar xzf $latest_openssl.tar.gz --exclude $latest_openssl/Makefile
-(
- cd $latest_openssl
- ./Configure --prefix=$install_prefix mingw64 \
- --cross-compile-prefix=$compiler_prefix-
-
- # Avoid recompilation by caching the previous Makefile for its timestamp,
- # and reusing if it hasn't changed.
- if diff --brief Makefile ../openssl.makefile.cache; then
- cp -a ../openssl.makefile.cache Makefile
- else
- cp -a Makefile ../openssl.makefile.cache
- fi
-
- make
- make install_sw
-)
-
-pcre_url=`wget -O- -q ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/ \
-| grep 'pcre-8.*.tar.bz2"' | sed -e 's/">pcre-.*//' | sed -e 's/.*<a href="//' \
-| tail -1`
-pcre_version=`basename $pcre_url .tar.bz2`
-wget -c $pcre_url
-tar xjf `basename $pcre_url`
-(
- cd $pcre_version
- ./configure --prefix=$install_prefix --disable-shared \
- --host=$compiler_prefix
- make
- make install
-)
-
diff --git a/infrastructure/mingw/configure.sh b/infrastructure/mingw/configure.sh
deleted file mode 100755
index 98c0cb49..00000000
--- a/infrastructure/mingw/configure.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/bin/sh
-
-source `dirname $0`/environment.sh
-
-if [ ! -r "$DEP_PATH/lib/libssl.a" ]; then
- echo "Error: install OpenSSL as instructed by" \
- "docs/backup/win32_build_on_cygwin_using_mingw.txt" >&2
- exit 2
-fi
-
-if [ ! -r "$DEP_PATH/lib/libpcreposix.a" \
- -o ! -r "$DEP_PATH/lib/libpcre.a" \
- -o ! -r "$DEP_PATH/include/pcreposix.h" ]; then
- echo "Error: install PCRE as instructed by" \
- "docs/backup/win32_build_on_cygwin_using_mingw.txt" >&2
- exit 2
-fi
-
-LIBZ_PATH="${DEP_PATH}/sys-root/mingw/lib"
-
-if [ ! -r "$LIBZ_PATH/libz.dll.a" ]; then
- echo "Error: upgrade your Cygwin mingw-zlib-devel package" >&2
- exit 2
-fi
-
-if [ ! -x "configure" ]; then
- if ! ./bootstrap; then
- echo "Error: bootstrap failed, aborting." >&2
- exit 1
- fi
-fi
-
-if ! ./configure "$@" --host=$target \
- --with-ssl-headers="${DEP_PATH}/include" \
- --with-ssl-lib="${DEP_PATH}/lib" \
- CFLAGS="-mthreads" \
- CXXFLAGS="-mthreads" \
- LDFLAGS="-Wl,-Bstatic -mthreads -L${LIBZ_PATH}" \
- LIBS="-lws2_32 -lgdi32"
-then
- echo "Error: configure failed, aborting." >&2
- exit 1
-fi
-
-exit 0
diff --git a/infrastructure/mingw/environment.sh b/infrastructure/mingw/environment.sh
deleted file mode 100644
index 1f2f14c2..00000000
--- a/infrastructure/mingw/environment.sh
+++ /dev/null
@@ -1,11 +0,0 @@
-case "`uname -m`" in
-x86_64)
- DEP_PATH=/usr/x86_64-w64-mingw32
- target=x86_64-w64-mingw32 ;;
-i686)
- DEP_PATH=/usr/i686-pc-mingw32
- target=i686-pc-mingw32 ;;
-*)
- echo "Error: unknown machine type `uname -m`" >&2; exit 1 ;;
-esac
-
diff --git a/infrastructure/mingw/runtest.sh b/infrastructure/mingw/runtest.sh
deleted file mode 100755
index 4deecb47..00000000
--- a/infrastructure/mingw/runtest.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-source `dirname $0`/environment.sh
-
-export PATH=$DEP_PATH/sys-root/mingw/bin:$PATH
-
-exec `dirname $0`/../../runtest.pl "$@"