summaryrefslogtreecommitdiff
path: root/infrastructure/parcelpath.pl
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-10-05 15:14:24 +0000
committerChris Wilson <chris+github@qwirx.com>2008-10-05 15:14:24 +0000
commitef0777633f49ac643c7184cb2c26dcb798eaf1c6 (patch)
treead8146df952a19ef79a8f4a6ddd92b406dae7ff1 /infrastructure/parcelpath.pl
parent31c892532d5be4ebb92d26f35f726c1fbbfd6fba (diff)
Move parcel_* functions into BoxPlatform package to share them with
other scripts. Add a script to print the path to the current parcel directory, for use in configure.ac to allow this to be placed in substitutions (contrib/windows/installer/boxbackup.mpi in particular).
Diffstat (limited to 'infrastructure/parcelpath.pl')
-rw-r--r--infrastructure/parcelpath.pl17
1 files changed, 17 insertions, 0 deletions
diff --git a/infrastructure/parcelpath.pl b/infrastructure/parcelpath.pl
new file mode 100644
index 00000000..24f951a2
--- /dev/null
+++ b/infrastructure/parcelpath.pl
@@ -0,0 +1,17 @@
+#!perl
+
+unless (@ARGV == 2)
+{
+ die "Usage: $0 <parcel-name> <target-os>\n";
+}
+
+$basedir = $0;
+$basedir =~ s|/.*||;
+$basedir .= "/..";
+-d $basedir or die "$basedir: $!";
+chdir $basedir or die "$basedir: $!";
+require "infrastructure/BoxPlatform.pm.in";
+
+print BoxPlatform::parcel_dir(@ARGV) . "\n";
+
+exit 0;