summaryrefslogtreecommitdiff
path: root/infrastructure
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2008-02-02 08:31:52 +0100
committerReinhard Tartler <siretart@tauware.de>2008-02-02 08:31:52 +0100
commit2787035d98661881477d696403ca2a78b49322d5 (patch)
tree0a018e13726a0232332ac23565e1a7df32cdcc06 /infrastructure
parent2733267954e91e394fbb512ea3abb4c497c0752f (diff)
import version 0.11rc2
This commit has been made by 'bzr import'. I used the upstream tarball of Version 0.11rc2 for creating it. It has the md5sum: 68052f963a944c717a50bd65a54375ff
Diffstat (limited to 'infrastructure')
-rw-r--r--infrastructure/buildenv-testmain-template.cpp5
-rw-r--r--infrastructure/m4/ax_check_syscall_lseek.m415
-rwxr-xr-xinfrastructure/makebuildenv.pl.in18
-rwxr-xr-xinfrastructure/makedistribution.pl.in29
-rwxr-xr-xinfrastructure/makeparcels.pl.in42
-rw-r--r--infrastructure/msvc/getversion.pl5
6 files changed, 80 insertions, 34 deletions
diff --git a/infrastructure/buildenv-testmain-template.cpp b/infrastructure/buildenv-testmain-template.cpp
index 9922a584..e803add2 100644
--- a/infrastructure/buildenv-testmain-template.cpp
+++ b/infrastructure/buildenv-testmain-template.cpp
@@ -1,11 +1,12 @@
-// distribution boxbackup-0.11rc1 (svn version: 2023_2024)
+// distribution boxbackup-0.11rc2 (svn version: 2072)
//
-// Copyright (c) 2003 - 2006
+// Copyright (c) 2003 - 2008
// Ben Summers and contributors. All rights reserved.
//
// Redistribution and use in source and binary forms, with or without
// modification, are permitted provided that the following conditions
// are met:
+//
// 1. Redistributions of source code must retain the above copyright
// notice, this list of conditions and the following disclaimer.
// 2. Redistributions in binary form must reproduce the above copyright
diff --git a/infrastructure/m4/ax_check_syscall_lseek.m4 b/infrastructure/m4/ax_check_syscall_lseek.m4
index 6bf93c23..491cc1ed 100644
--- a/infrastructure/m4/ax_check_syscall_lseek.m4
+++ b/infrastructure/m4/ax_check_syscall_lseek.m4
@@ -24,7 +24,7 @@ AC_DEFUN([AX_CHECK_SYSCALL_LSEEK], [
#ifdef HAVE___SYSCALL_NEED_DEFN
extern "C" off_t __syscall(quad_t number, ...);
#endif
- #ifndef HAVE_SYSCALL
+ #ifdef HAVE___SYSCALL // always use it if we have it
#undef syscall
#define syscall __syscall
#endif
@@ -33,7 +33,18 @@ AC_DEFUN([AX_CHECK_SYSCALL_LSEEK], [
int res = 0;
if(fh>=0)
{
- res = syscall(SYS_lseek, fh, 0, SEEK_SET, 99);
+ // This test tries first to seek to position 0, with NO
+ // "dummy argument". If lseek does actually require a dummy
+ // argument, then it will eat SEEK_SET for the offset and
+ // try to use 99 as whence, which is invalid, so res will be
+ // -1, the program will return zero and
+ // have_lseek_dummy_param=yes
+ // (whew! that took 1 hour to figure out)
+ // The "dummy argument" probably means that it takes a 64-bit
+ // offset, so this was probably a bug anyway, and now that
+ // we cast the offset to off_t, it should never be needed
+ // (if my reasoning is correct).
+ res = syscall(SYS_lseek, fh, (off_t)0, SEEK_SET, 99);
close(fh);
}
unlink("lseektest");
diff --git a/infrastructure/makebuildenv.pl.in b/infrastructure/makebuildenv.pl.in
index 8664f3d7..456bd265 100755
--- a/infrastructure/makebuildenv.pl.in
+++ b/infrastructure/makebuildenv.pl.in
@@ -12,7 +12,7 @@ $|=1;
# note: Mac OS X resource forks and .DS_Store files are explicity ignored
-print "Box build environment setup.\n\n";
+print "Box build environment setup.\n";
my @implicit_deps = ('lib/common');
@@ -20,6 +20,8 @@ my @implicit_deps = ('lib/common');
use lib 'infrastructure';
use BoxPlatform;
+print "Building on '$build_os'.\n\n";
+
# keep copy of command line args
my $makebuildenv_args = join(' ',@ARGV);
@@ -525,19 +527,19 @@ __E
# do not edit!
#
#
-CXX = "@CXX@"
-AR = "@AR@"
-RANLIB = "@RANLIB@"
-PERL = "@PERL@"
+CXX = @CXX@
+AR = @AR@
+RANLIB = @RANLIB@
+PERL = @PERL@
WINDRES = windres
.ifdef RELEASE
-CXXFLAGS = -DNDEBUG $release_flags -Wall -Wundef $include_paths $extra_platform_defines -DBOX_VERSION="\\"$product_version\\""
+CXXFLAGS = -DNDEBUG $release_flags @CXXFLAGS_STRICT@ $include_paths $extra_platform_defines -DBOX_VERSION="\\"$product_version\\""
OUTBASE = ../../release
OUTDIR = ../../release/$mod
DEPENDMAKEFLAGS = -D RELEASE
VARIENT = RELEASE
.else
-CXXFLAGS = -g -Wall -Wundef $include_paths $extra_platform_defines -DBOX_VERSION="\\"$product_version\\""
+CXXFLAGS = -g @CXXFLAGS_STRICT@ $include_paths $extra_platform_defines -DBOX_VERSION="\\"$product_version\\""
OUTBASE = ../../debug
OUTDIR = ../../debug/$mod
DEPENDMAKEFLAGS =
@@ -741,7 +743,7 @@ __E
additional_objects_from_make_fragment("$mod/Makefile.extra", \@objs, \@makefile_includes);
additional_objects_from_make_fragment("$mod/Makefile.extra.$build_os", \@objs, \@makefile_includes);
- my $o_file_list = join(' ',map {'$(OUTDIR)/'.$_.'.o'} @objs);
+ my $o_file_list = join(' ',map {'$(OUTDIR)/'.$_.'.o'} sort @objs);
if ($has_deps and not $bsd_make)
{
diff --git a/infrastructure/makedistribution.pl.in b/infrastructure/makedistribution.pl.in
index 314259f6..2ef8b960 100755
--- a/infrastructure/makedistribution.pl.in
+++ b/infrastructure/makedistribution.pl.in
@@ -1,5 +1,5 @@
-#!/usr/bin/perl
#!@PERL@
+
use strict;
use Symbol;
@@ -82,11 +82,11 @@ sub copy_from_list
my $list = $_[0];
open LIST,$list or die "Can't open $list";
- while(<LIST>)
+ while(my $line = <LIST>)
{
- next unless m/\S/;
- chomp;
- my ($src,$dst) = split /\s+/;
+ next unless $line =~ m/\S/;
+ chomp $line;
+ my ($src,$dst,$other) = split /\s+/, $line;
$dst = $src if $dst eq '';
if($src eq 'MKDIR')
{
@@ -95,8 +95,16 @@ sub copy_from_list
}
elsif($src eq 'NO-LICENSE-IN-DIR')
{
+ my ($junk,$spec) = split /\s+/, $line;
# record that this directory shouldn't have the license added
$no_license_dir{$dst} = 1;
+
+ # actually copy it, to remove redundancy in manifests
+ $src = $dst;
+ $dst = $other;
+ $dst = $src if $dst eq '';
+ $modules_included{$spec} = 1;
+ copy_dir($src,$dst);
}
elsif($src eq 'REPLACE-VERSION-IN')
{
@@ -108,16 +116,17 @@ sub copy_from_list
}
elsif($src eq 'RUN')
{
- print "Running $dst...\n";
- if(system($dst) != 0)
+ my ($junk,$cmd) = split /\s+/, $line, 2;
+ print "Running $cmd...\n";
+ if(system($cmd) != 0)
{
- print "Error running $dst. Aborting.\n";
+ print "Error running $cmd. Aborting.\n";
exit(1);
}
}
elsif(-d $src)
{
- $modules_included{$_} = 1;
+ $modules_included{$line} = 1;
copy_dir($src,$dst);
}
else
@@ -322,6 +331,8 @@ sub copy_dir
next if m/\A_/;
next if m/\AMakefile\Z/;
next if m/\Aautogen/;
+ next if m/-smf-method\Z/; # copy only the .in versions
+ next if m/-manifest.xml\Z/; # copy onlt the .in versions
next if !-f "$dir/$_";
copy_file("$dir/$_","$dst_dir/$_");
diff --git a/infrastructure/makeparcels.pl.in b/infrastructure/makeparcels.pl.in
index 0846ef46..125ff346 100755
--- a/infrastructure/makeparcels.pl.in
+++ b/infrastructure/makeparcels.pl.in
@@ -7,6 +7,24 @@ use BoxPlatform;
my @parcels;
my %parcel_contents;
+sub starts_with ($$)
+{
+ my ($string,$expected) = @_;
+ return substr($string, 0, length $expected) eq $expected;
+}
+
+sub os_matches ($)
+{
+ my ($prefix_string) = @_;
+ my @prefixes = split m'\,', $prefix_string;
+ foreach my $prefix (@prefixes)
+ {
+ return 1 if starts_with($build_os, $prefix);
+ return 1 if starts_with($target_os, $prefix);
+ }
+ return 0;
+}
+
open PARCELS,"parcels.txt" or die "Can't open parcels file";
{
my $cur_parcel = '';
@@ -19,7 +37,7 @@ open PARCELS,"parcels.txt" or die "Can't open parcels file";
next if m/\AEND-OMIT/;
if(m/\AOMIT:(.+)/)
{
- if($1 eq $build_os or $1 eq $target_os)
+ if (os_matches($1))
{
while(<PARCELS>)
{
@@ -31,10 +49,7 @@ open PARCELS,"parcels.txt" or die "Can't open parcels file";
if (m'\AONLY:(.+)')
{
- my @only_targets = split m'\,', $1;
-
- if (not grep {$_ eq $build_os or $_ eq $target_os}
- @only_targets)
+ if (not os_matches($1))
{
while (<PARCELS>)
{
@@ -110,14 +125,14 @@ for my $parcel (@parcels)
for(@{$parcel_contents{$parcel}})
{
- my ($type,$name) = split /\s+/;
+ my ($type,$name,$dest) = split /\s+/;
my $optional = '';
if ($type eq 'optional')
{
- ($optional,$type,$name) = split /\s+/;
+ ($optional,$type,$name,$dest) = split /\s+/;
}
-
+
if($type eq 'bin')
{
my $exeext = $platform_exe_ext;
@@ -136,13 +151,18 @@ for my $parcel (@parcels)
print MAKE "\tcp $name $dir\n";
}
# remove path from script name
- $name =~ m~/([^/]+)\Z~;
- $name = $1;
+ $name =~ s{.*/}{};
}
unless ($target_windows)
{
- print SCRIPT "install $name $install_into_dir\n";
+ my $local_install_dir = $install_into_dir;
+ if (defined $dest)
+ {
+ $local_install_dir = "@prefix@/$dest";
+ }
+ print SCRIPT "install $name " .
+ "\$DESTDIR$local_install_dir\n";
}
}
diff --git a/infrastructure/msvc/getversion.pl b/infrastructure/msvc/getversion.pl
index 819ba1b2..120992c4 100644
--- a/infrastructure/msvc/getversion.pl
+++ b/infrastructure/msvc/getversion.pl
@@ -1,12 +1,13 @@
#!perl
-# distribution boxbackup-0.11rc1 (svn version: 2023_2024)
+# distribution boxbackup-0.11rc2 (svn version: 2072)
#
-# Copyright (c) 2003 - 2006
+# Copyright (c) 2003 - 2008
# Ben Summers and contributors. All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions
# are met:
+#
# 1. Redistributions of source code must retain the above copyright
# notice, this list of conditions and the following disclaimer.
# 2. Redistributions in binary form must reproduce the above copyright