summaryrefslogtreecommitdiff
path: root/infrastructure
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2017-06-14 19:53:34 -0400
committerReinhard Tartler <siretart@tauware.de>2017-06-14 19:55:14 -0400
commite0c122119afea4c951c0c57144d26a473118c254 (patch)
tree34a02a56f9b017201dfb721ef678c711351466d6 /infrastructure
parente0eb815b67734abd09ff41e2271630d4b2a6d760 (diff)
Fixup botched merge
Diffstat (limited to 'infrastructure')
-rw-r--r--infrastructure/BoxPlatform.pm.in22
-rw-r--r--infrastructure/buildenv-testmain-template.cpp57
-rw-r--r--infrastructure/m4/ax_check_ssl.m44
-rw-r--r--infrastructure/m4/vl_lib_readline.m420
-rwxr-xr-xinfrastructure/makebuildenv.pl.in71
-rwxr-xr-xinfrastructure/makeparcels.pl.in60
-rwxr-xr-xinfrastructure/mingw/configure.sh13
-rw-r--r--infrastructure/msvc/getversion.pl8
8 files changed, 0 insertions, 255 deletions
diff --git a/infrastructure/BoxPlatform.pm.in b/infrastructure/BoxPlatform.pm.in
index f3c71308..b2b2ce43 100644
--- a/infrastructure/BoxPlatform.pm.in
+++ b/infrastructure/BoxPlatform.pm.in
@@ -24,13 +24,6 @@ BEGIN
# Cygwin Builds usually something like CYGWIN_NT-5.0, CYGWIN_NT-5.1
# Box Backup tried on Win2000,XP only :)
$build_os = 'CYGWIN' if $build_os =~ m/CYGWIN/;
-<<<<<<< HEAD
-
- $make_command = ($build_os eq 'Darwin') ? 'bsdmake' : ($build_os eq 'SunOS') ? 'gmake' : 'make';
-
- $bsd_make = ($build_os ne 'Linux' && $build_os ne 'CYGWIN' &&
- $build_os ne "SunOS" && $build_os ne 'GNU/kFreeBSD');
-=======
$build_os = 'MINGW32' if $build_os =~ m/MINGW32/;
if ($build_os eq 'Darwin') {
@@ -42,7 +35,6 @@ BEGIN
$bsd_make = ($build_os ne 'Linux' && $build_os ne 'CYGWIN' &&
$build_os ne "MINGW32" && $build_os ne "SunOS"
&& $build_os ne 'GNU/kFreeBSD' && $xcode_ver < 4);
->>>>>>> 0.12
# blank extra flags by default
$platform_compile_line_extra = '';
@@ -96,19 +88,6 @@ BEGIN
# where to put the files
$install_into_dir = '@sbindir_expanded@';
-<<<<<<< HEAD
- # if it's Darwin,
- if($build_os eq 'Darwin')
- {
- # see how many processors there are, and set make flags accordingly
- my $cpus = `sysctl hw.ncpu`;
- if($cpus =~ m/hw.ncpu:\s(\d+)/ && $1 > 1)
- {
- print STDERR "$1 processors detected, will set make to perform concurrent jobs\n";
- $sub_make_options = ' -j '.($1 + 1);
- }
-
-=======
# see how many processors there are, and set make flags accordingly
if($build_os eq 'Darwin' || $build_os =~ /(Free|Net|Open)BSD/)
{
@@ -133,7 +112,6 @@ BEGIN
# if it's Darwin,
if($build_os eq 'Darwin')
{
->>>>>>> 0.12
# test for fink installation
if(-d '/sw/include' && -d '/sw/lib')
{
diff --git a/infrastructure/buildenv-testmain-template.cpp b/infrastructure/buildenv-testmain-template.cpp
index 287c4bff..e5b1360d 100644
--- a/infrastructure/buildenv-testmain-template.cpp
+++ b/infrastructure/buildenv-testmain-template.cpp
@@ -29,11 +29,6 @@
#include <getopt.h>
#endif
-<<<<<<< HEAD
-#include <sys/stat.h>
-#include <sys/types.h>
-
-=======
#ifdef HAVE_SYS_SOCKET_H
# include <sys/socket.h>
#endif
@@ -45,7 +40,6 @@
# include <sys/un.h>
#endif
->>>>>>> 0.12
#include <exception>
#include <string>
@@ -90,9 +84,6 @@ inline bool checkfilesleftopen() { return false; }
#define FILEDES_MAX 256
-<<<<<<< HEAD
-bool filedes_open[FILEDES_MAX];
-=======
typedef enum
{
OPEN,
@@ -102,7 +93,6 @@ typedef enum
filedes_t;
filedes_t filedes_open[FILEDES_MAX];
->>>>>>> 0.12
bool check_filedes(bool report)
{
@@ -113,13 +103,6 @@ bool check_filedes(bool report)
{
if(::fcntl(d, F_GETFD) != -1)
{
-<<<<<<< HEAD
- // File descriptor obviously exists
- if (report && !filedes_open[d])
- {
- struct stat st;
- if (fstat(d, &st) == 0)
-=======
// File descriptor obviously exists, but is it /dev/log?
struct stat st;
@@ -165,7 +148,6 @@ bool check_filedes(bool report)
// ignore it.
}
else if(stat_success)
->>>>>>> 0.12
{
int m = st.st_mode;
#define flag(x) ((m & x) ? #x " " : "")
@@ -179,47 +161,22 @@ bool check_filedes(bool report)
flag(S_IFLNK) <<
flag(S_IFSOCK) <<
" or " << m << ")");
-<<<<<<< HEAD
-=======
allOk = false;
->>>>>>> 0.12
}
else
{
BOX_FATAL("File descriptor " << d <<
" left open (and stat failed)");
-<<<<<<< HEAD
- }
-
- allOk = false;
-
- }
- else if (!report)
- {
- filedes_open[d] = true;
-=======
allOk = false;
}
}
else if (!report)
{
filedes_open[d] = is_syslog_socket ? SYSLOG : OPEN;
->>>>>>> 0.12
}
}
else
{
-<<<<<<< HEAD
- if (report && filedes_open[d])
- {
- BOX_FATAL("File descriptor " << d <<
- " was open, now closed");
- allOk = false;
- }
- else
- {
- filedes_open[d] = false;
-=======
if (report && filedes_open[d] != CLOSED)
{
if (filedes_open[d] == SYSLOG)
@@ -239,7 +196,6 @@ bool check_filedes(bool report)
else
{
filedes_open[d] = CLOSED;
->>>>>>> 0.12
}
}
}
@@ -292,11 +248,7 @@ int main(int argc, char * const * argv)
int ch;
-<<<<<<< HEAD
- while ((ch = getopt_long(argc, argv, "c:d:qs:t:vPTUV", longopts, NULL))
-=======
while ((ch = getopt_long(argc, argv, "c:d:qs:t:vPTUVW:", longopts, NULL))
->>>>>>> 0.12
!= -1)
{
switch(ch)
@@ -368,8 +320,6 @@ int main(int argc, char * const * argv)
}
break;
-<<<<<<< HEAD
-=======
case 'W':
{
logLevel = Logging::GetNamedLevel(optarg);
@@ -381,7 +331,6 @@ int main(int argc, char * const * argv)
}
break;
->>>>>>> 0.12
case 't':
{
Logging::SetProgramName(optarg);
@@ -419,10 +368,7 @@ int main(int argc, char * const * argv)
}
Logging::SetGlobalLevel((Log::Level)logLevel);
-<<<<<<< HEAD
-=======
Logging::FilterConsole((Log::Level)logLevel);
->>>>>>> 0.12
argc -= optind - 1;
argv += optind - 1;
@@ -500,15 +446,12 @@ int main(int argc, char * const * argv)
return returncode;
}
-<<<<<<< HEAD
-=======
catch(BoxException &e)
{
printf("FAILED: Exception caught: %s: %s\n", e.what(),
e.GetMessage().c_str());
return 1;
}
->>>>>>> 0.12
catch(std::exception &e)
{
printf("FAILED: Exception caught: %s\n", e.what());
diff --git a/infrastructure/m4/ax_check_ssl.m4 b/infrastructure/m4/ax_check_ssl.m4
index 1714080c..78b99f7e 100644
--- a/infrastructure/m4/ax_check_ssl.m4
+++ b/infrastructure/m4/ax_check_ssl.m4
@@ -27,12 +27,8 @@ AC_DEFUN([AX_CHECK_SSL], [
ax_check_ssl_found=yes
AC_CHECK_HEADERS([openssl/ssl.h],, [ax_check_ssl_found=no])
-<<<<<<< HEAD
- AC_CHECK_LIB([ssl], [SSL_read],, [ax_check_ssl_found=no], [-lcrypto])
-=======
AC_SEARCH_LIBS([HMAC_CTX_init], [crypto])
AC_SEARCH_LIBS([SSL_read], [ssl],, [ax_check_ssl_found=no])
->>>>>>> 0.12
if test "x$ax_check_ssl_found" = "xyes"; then
AC_DEFINE([HAVE_SSL], 1, [Define to 1 if SSL is available])
diff --git a/infrastructure/m4/vl_lib_readline.m4 b/infrastructure/m4/vl_lib_readline.m4
index e04a5f5f..e9cb72b8 100644
--- a/infrastructure/m4/vl_lib_readline.m4
+++ b/infrastructure/m4/vl_lib_readline.m4
@@ -79,16 +79,6 @@ AC_DEFUN([VL_LIB_READLINE], [
fi
])
-<<<<<<< HEAD
-dnl VL_LIB_READLINE_CHECK(name, libraries, headers, history headers)
-AC_DEFUN([VL_LIB_READLINE_CHECK], [
- AC_CACHE_CHECK([for $1 library],
- [vl_cv_lib_$1], [
- ORIG_LIBS="$LIBS"
- vl_cv_lib_$1=""
- for readline_lib in $2; do
- for termcap_lib in "" termcap curses ncurses; do
-=======
dnl BOX_CHECK_VAR(name, where, headers)
AC_DEFUN([BOX_CHECK_VAR], [
AC_CACHE_CHECK([for $1 $2], [vl_cv_var_$1],
@@ -107,7 +97,6 @@ AC_DEFUN([VL_LIB_READLINE_CHECK], [
vl_cv_lib_$1=""
for readline_lib in $2; do
for termcap_lib in "" termcap curses ncurses pdcurses; do
->>>>>>> 0.12
if test -z "$termcap_lib"; then
TRY_LIB="-l$readline_lib"
else
@@ -129,14 +118,6 @@ AC_DEFUN([VL_LIB_READLINE_CHECK], [
fi
])
-<<<<<<< HEAD
- vl_cv_lib_readline_compat_found=no
- if test "x$vl_cv_lib_$1" != "xno"; then
- AC_CHECK_HEADERS([$3], [vl_cv_lib_readline_compat_found=yes])
- fi
-
- if test "x$vl_cv_lib_readline_compat_found" = "xyes"; then
-=======
vl_cv_lib_includes=""
vl_cv_lib_readline_compat_found=no
@@ -166,7 +147,6 @@ $vl_cv_lib_includes"
BOX_CHECK_VAR([completion_matches], [in readline headers],
[$vl_cv_lib_includes])
->>>>>>> 0.12
AC_DEFINE([HAVE_LIBREADLINE], 1,
[Define if you have a readline compatible library])
diff --git a/infrastructure/makebuildenv.pl.in b/infrastructure/makebuildenv.pl.in
index ed963c93..005f2d25 100755
--- a/infrastructure/makebuildenv.pl.in
+++ b/infrastructure/makebuildenv.pl.in
@@ -261,11 +261,7 @@ for(@modules_files)
push @modules,$mod;
my @md; # module dependencies
my @lo; # link line options
-<<<<<<< HEAD
- for(@deps)
-=======
for (@deps)
->>>>>>> 0.12
{
if(/\A-l/)
{
@@ -281,11 +277,7 @@ for(@modules_files)
# make directories, but not if we're using an external library and this a library module
my ($s,$d) = split /\//,$mod;
-<<<<<<< HEAD
- if($s ne 'lib' || $external_lib eq '')
-=======
if ($s ne 'lib' or $external_lib eq '')
->>>>>>> 0.12
{
mkdir "release/$s",0755;
mkdir "release/$s/$d",0755;
@@ -354,12 +346,8 @@ for my $mod (@modules, @implicit_deps)
for(grep /\.h\Z/i, @items)
{
next if /\A\._/; # Temp Mac OS Resource hack
-<<<<<<< HEAD
- die "Header file $_ already used in module ".$hfiles{$_}."\n" if exists $hfiles{$_};
-=======
die "Header file $_ already used in module ".$hfiles{$_}.
", cannot add to $mod\n" if exists $hfiles{$_};
->>>>>>> 0.12
$hfiles{$_} = $mod
}
}
@@ -388,18 +376,11 @@ for my $mod (@modules, @implicit_deps)
closedir DIR;
}
-<<<<<<< HEAD
-=======
# Then write a makefile for each module
->>>>>>> 0.12
print "done\n\nGenerating Makefiles...\n";
my %module_resources_win32;
-<<<<<<< HEAD
-# Then write a makefile for each module
-=======
->>>>>>> 0.12
for my $mod (@implicit_deps, @modules)
{
print $mod,"\n";
@@ -503,10 +484,7 @@ __E
}
my @all_deps_for_module;
-<<<<<<< HEAD
-=======
->>>>>>> 0.12
{
# work out what dependencies need to be run
my @deps_raw;
@@ -590,27 +568,16 @@ WINDRES = @WINDRES@
DEFAULT_CXXFLAGS = @CPPFLAGS@ $default_cxxflags @CXXFLAGS_STRICT@ \\
$include_paths $extra_platform_defines \\
-DBOX_VERSION="\\"$product_version\\""
-<<<<<<< HEAD
-LDFLAGS = @LDFLAGS@ @LDADD_RDYNAMIC@
-
-.ifdef RELEASE
-CXXFLAGS = -DBOX_RELEASE_BUILD $release_flags \$(DEFAULT_CXXFLAGS)
-=======
LDFLAGS += @LDFLAGS@ @LDADD_RDYNAMIC@
.ifdef RELEASE
CXXFLAGS += -DBOX_RELEASE_BUILD $release_flags \$(DEFAULT_CXXFLAGS)
->>>>>>> 0.12
OUTBASE = ../../release
OUTDIR = ../../release/$mod
DEPENDMAKEFLAGS = -D RELEASE
VARIENT = RELEASE
.else
-<<<<<<< HEAD
-CXXFLAGS = -g \$(DEFAULT_CXXFLAGS)
-=======
CXXFLAGS += -g \$(DEFAULT_CXXFLAGS)
->>>>>>> 0.12
OUTBASE = ../../debug
OUTDIR = ../../debug/$mod
DEPENDMAKEFLAGS =
@@ -655,15 +622,12 @@ _PERL = \$(if \$(V),\$(PERL), @ echo " [PERL] \$@" && \$(PERL) >/dev/n
__E
}
-<<<<<<< HEAD
-=======
# if there is a Makefile.pre, include it now
if(-e "$mod/Makefile.pre")
{
print MAKE ".include <Makefile.pre>\n\n";
}
->>>>>>> 0.12
# read directory
opendir DIR,$mod;
@@ -784,11 +748,7 @@ __E
$has_deps = 1;
$has_deps = 0 if $target_is_library;
-<<<<<<< HEAD
- # Depenency stuff
-=======
# Dependency stuff
->>>>>>> 0.12
my $deps_makeinfo;
if($has_deps)
{
@@ -814,9 +774,6 @@ __E
# run make for things we require
for my $dep (@all_deps_for_module)
{
-<<<<<<< HEAD
- $deps_makeinfo .= "\t\t\$(HIDE) (cd ../../$dep; \$(MAKE)$sub_make_options -q \$(DEPENDMAKEFLAGS) -D NODEPS || \$(MAKE)$sub_make_options \$(DEPENDMAKEFLAGS) -D NODEPS)\n";
-=======
my $dep_target = "";
if ($dep =~ m|^lib/(.*)|)
{
@@ -838,17 +795,12 @@ __E
|| \$(MAKE) $sub_make_options \$(DEPENDMAKEFLAGS) -D NODEPS $dep_target \\
)
EOF
->>>>>>> 0.12
}
$deps_makeinfo .= ".\tendif\n.endif\n\n";
}
print MAKE $deps_makeinfo if $bsd_make;
-<<<<<<< HEAD
- # get the list of library things to add -- in order of dependency so things link properly
- my $lib_files = join(' ',map {($_ =~ m/lib\/(.+)\Z/)?('$(OUTBASE)/'.$_.'/'.$1.'.a'):undef} (reverse(@all_deps_for_module)));
-=======
# get the list of library things to add -- in order of dependency
# so things link properly
my @lib_files;
@@ -863,7 +815,6 @@ EOF
push @lib_files, "../../$dep/lib$1.a";
}
}
->>>>>>> 0.12
# need to see if the extra makefile fragments require extra object files
# or include any more makefiles
@@ -882,11 +833,7 @@ EOF
}
print MAKE $end_target,': ',$o_file_list;
-<<<<<<< HEAD
- print MAKE " ",$lib_files unless $target_is_library;
-=======
print MAKE " @lib_files" unless $target_is_library;
->>>>>>> 0.12
print MAKE "\n";
if ($target_windows)
@@ -913,15 +860,6 @@ EOF
# work out library options
# need to be... least used first, in absolute order they appear in the modules.txt file
my @libops;
-<<<<<<< HEAD
- sub libops_fill
- {
- my ($m,$r) = @_;
- push @$r,$_ for(@{$module_library_link_opts{$m}});
- libops_fill($_,$r) for(@{$module_dependency{$m}});
- }
- libops_fill($mod,\@libops);
-=======
sub libops_fill
{
@@ -942,7 +880,6 @@ EOF
libops_fill($mod,\@libops);
->>>>>>> 0.12
my $lo = '';
my %ldone;
for(@libops)
@@ -955,24 +892,16 @@ EOF
# link line...
print MAKE "\t\$(_LINK) \$(LDFLAGS) $link_line_extra " .
"-o $end_target $o_file_list " .
-<<<<<<< HEAD
- "$lib_files$lo $platform_lib_files\n";
- }
-=======
"@lib_files $lo $platform_lib_files\n";
}
->>>>>>> 0.12
# tests need to copy the test file over
if($type eq 'test')
{
print MAKE "\tcp _t \$(OUTDIR)/t\n\tchmod u+x \$(OUTDIR)/t\n";
print MAKE "\tcp _t-gdb \$(OUTDIR)/t-gdb\n\tchmod u+x \$(OUTDIR)/t-gdb\n";
}
-<<<<<<< HEAD
-=======
->>>>>>> 0.12
# dependency line?
print MAKE "\n";
diff --git a/infrastructure/makeparcels.pl.in b/infrastructure/makeparcels.pl.in
index f468dc1f..5afdf730 100755
--- a/infrastructure/makeparcels.pl.in
+++ b/infrastructure/makeparcels.pl.in
@@ -123,11 +123,7 @@ release/common/test:
.PHONY: docs
docs:
-<<<<<<< HEAD
- \$(MAKE) -C docs
-=======
cd docs; \$(MAKE)
->>>>>>> 0.12
__END_OF_FRAGMENT
@@ -141,12 +137,9 @@ for my $parcel (@parcels)
my $dir = BoxPlatform::parcel_dir($parcel);
my @parcel_deps;
-<<<<<<< HEAD
-=======
# Need to use BSD install on Solaris
my $install_bin = $build_os eq 'SunOS' ? '/usr/ucb/install' : 'install';
->>>>>>> 0.12
unless ($target_windows)
{
open SCRIPT,">parcels/scripts/install-$parcel" or die
@@ -227,18 +220,11 @@ $dir/${name}.gz: docs/man/${name}.gz
EOF
# Releases have the docs pre-made, but users
# may want to rebuild them for some reason.
-<<<<<<< HEAD
- print MAKE <<EOF;
-.PHONY: docs/man/${name}.gz
-docs/man/${name}.gz:
- \$(MAKE) -C docs man/${name}.gz
-=======
my $docbook_source = "docs/docbook/${name}";
$docbook_source =~ s/\.[58]$/.xml/;
print MAKE <<EOF;
docs/man/${name}.gz: $docbook_source docs/docbook/bb-man.xsl
cd docs; \$(MAKE) man/${name}.gz
->>>>>>> 0.12
EOF
push @parcel_deps, "$dir/${name}.gz";
@@ -253,43 +239,26 @@ $dir/docs/${name}.html: docs/htmlguide/man-html/${name}.html
EOF
# Releases have the docs pre-made, but users
# may want to rebuild them for some reason.
-<<<<<<< HEAD
- print MAKE <<EOF;
-.PHONY: docs/htmlguide/man-html/${name}.html
-docs/htmlguide/man-html/${name}.html:
- \$(MAKE) -C docs htmlguide/man-html/${name}.html
-=======
my $docbook_source = "docs/docbook/${name}.xml";
print MAKE <<EOF;
docs/htmlguide/man-html/${name}.html: $docbook_source docs/docbook/bb-nochunk-book.xsl
cd docs; \$(MAKE) htmlguide/man-html/${name}.html
->>>>>>> 0.12
EOF
push @parcel_deps, "$dir/docs/${name}.html";
}
elsif ($type eq 'subdir')
{
-<<<<<<< HEAD
-=======
shift @args;
my $subdir = shift @args;
->>>>>>> 0.12
print MAKE <<EOF;
.PHONY: $name-build $name-clean
$name-build:
-<<<<<<< HEAD
- \$(MAKE) -C $name
-
-$name-clean:
- \$(MAKE) -C $name clean
-=======
cd $subdir; \$(MAKE) @args
$name-clean:
cd $name; \$(MAKE) clean
->>>>>>> 0.12
EOF
push @parcel_deps, "$name-build";
push @clean_deps, "$name-clean";
@@ -334,11 +303,7 @@ EOF
if ($type eq 'html')
{
-<<<<<<< HEAD
- $dest = "share/doc/$version";
-=======
$dest = "share/doc/@PACKAGE_TARNAME@";
->>>>>>> 0.12
$name = "docs/$name.html";
}
@@ -349,11 +314,7 @@ EOF
$name =~ s/$/\.gz/;
}
-<<<<<<< HEAD
- if ($install and not $target_windows)
-=======
if ($install and not $target_windows and not $type eq "subdir")
->>>>>>> 0.12
{
my $local_install_dir = $install_into_dir;
if (defined $dest)
@@ -370,11 +331,7 @@ EOF
}
print SCRIPT "mkdir -p " .
"\${DESTDIR}$local_install_dir/\n";
-<<<<<<< HEAD
- print SCRIPT "install $name " .
-=======
print SCRIPT "$install_bin $name " .
->>>>>>> 0.12
"\${DESTDIR}$local_install_dir\n";
}
}
@@ -408,22 +365,11 @@ install:
cat local/install.msg
clean: @clean_deps
-<<<<<<< HEAD
- \$(MAKE) -C docs clean
-=======
cd docs; \$(MAKE) clean
->>>>>>> 0.12
EOF
if ($build_os eq 'CYGWIN')
{
-<<<<<<< HEAD
- print MAKE "\tfind release debug -type f | xargs -r rm -f\n";
-}
-else
-{
- print MAKE "\tfind release debug -type f -exec rm -f {} \\;\n";
-=======
print MAKE "\tfind release debug -type f | xargs -r rm\n";
print MAKE "\tfind . -name 'autogen_*' -type f | xargs -r rm\n";
}
@@ -431,19 +377,13 @@ else
{
print MAKE "\tfind release debug -type f -exec rm -f {} \\;\n";
print MAKE "\tfind . -name 'autogen_*' -type f -exec rm -f {} \\;\n";
->>>>>>> 0.12
}
for my $parcel (@parcels)
{
-<<<<<<< HEAD
- print MAKE "\trm -rf ", BoxPlatform::parcel_dir($parcel), "\n";
- print MAKE "\trm -f ", BoxPlatform::parcel_target($parcel), "\n";
-=======
# need to use -f to avoid error if they don't exist (already cleaned)
print MAKE "\trm -rf ", BoxPlatform::parcel_dir($parcel), "\n";
print MAKE "\trm -f ", BoxPlatform::parcel_target($parcel), "\n";
->>>>>>> 0.12
}
close MAKE;
diff --git a/infrastructure/mingw/configure.sh b/infrastructure/mingw/configure.sh
index 5f16c558..46a61637 100755
--- a/infrastructure/mingw/configure.sh
+++ b/infrastructure/mingw/configure.sh
@@ -16,21 +16,12 @@ if [ ! -r "$DEP_PATH/lib/libpcreposix.a" \
exit 2
fi
-<<<<<<< HEAD
-export CXX="g++ -mno-cygwin"
-export LD="g++ -mno-cygwin"
-export CFLAGS="-mno-cygwin -mthreads"
-export CXXFLAGS="-mno-cygwin -mthreads"
-export LDFLAGS="-mno-cygwin -mthreads"
-export LIBS="-lcrypto -lws2_32 -lgdi32"
-=======
LIBZ_PATH="${DEP_PATH}/sys-root/mingw/lib"
if [ ! -r "$LIBZ_PATH/libz.dll.a" ]; then
echo "Error: upgrade your Cygwin mingw-zlib-devel package" >&2
exit 2
fi
->>>>>>> 0.12
if [ ! -x "configure" ]; then
if ! ./bootstrap; then
@@ -39,16 +30,12 @@ if [ ! -x "configure" ]; then
fi
fi
-<<<<<<< HEAD
-if ! ./configure --target=i686-pc-mingw32; then
-=======
if ! ./configure "$@" --target=i686-pc-mingw32 \
CFLAGS="-mno-cygwin -mthreads" \
CPPFLAGS="-mno-cygwin" \
CXXFLAGS="-mno-cygwin -mthreads" \
LDFLAGS="-Wl,-Bstatic -mno-cygwin -mthreads -L${DEP_PATH}/lib -L${LIBZ_PATH}"
then
->>>>>>> 0.12
echo "Error: configure failed, aborting." >&2
exit 1
fi
diff --git a/infrastructure/msvc/getversion.pl b/infrastructure/msvc/getversion.pl
index 42ae4b63..0cf9cbcb 100644
--- a/infrastructure/msvc/getversion.pl
+++ b/infrastructure/msvc/getversion.pl
@@ -11,13 +11,6 @@ chdir $basedir or die "$basedir: $!";
require "$basedir\\infrastructure\\BoxPlatform.pm.in";
-<<<<<<< HEAD
-open VERSIONFILE, "> $basedir/lib/common/BoxVersion.h"
- or die "BoxVersion.h: $!";
-print VERSIONFILE "#define BOX_VERSION \"$BoxPlatform::product_version\"\n";
-close VERSIONFILE;
-
-=======
my $verfile = "$basedir/lib/common/BoxVersion.h";
my $newver = "#define BOX_VERSION \"$BoxPlatform::product_version\"\n";
my $oldver = "";
@@ -38,5 +31,4 @@ if ($newver ne $oldver)
}
print $BoxPlatform::product_version;
->>>>>>> 0.12
exit 0;