summaryrefslogtreecommitdiff
path: root/infrastructure
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2016-09-03 00:14:08 +0100
committerChris Wilson <chris+github@qwirx.com>2016-09-03 00:14:08 +0100
commit11a8c444875d8b7912fa07bdc3854e3adb27aa4e (patch)
tree5c0c8a4e6910c4b81c5ca077f0753d3392716bc3 /infrastructure
parentc0125ee22e09a31ae291e42faa817835bd903dbc (diff)
Break dependency on Cygwin commands in Windows tests.
Define WIN32 properly when building with CMake, and in this case, use native commands such as attrib.exe instead of Cygwin chmod, so that users don't have to install Cygwin or msys-git.
Diffstat (limited to 'infrastructure')
-rw-r--r--infrastructure/cmake/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index 01405c6e..0838045a 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -89,6 +89,10 @@ if(NOT status EQUAL 0)
"status ${status}: ${command_output}")
endif()
+if(WIN32)
+ add_definitions(-DWIN32)
+endif()
+
# Parsing Makefile.extra files in CMake script is a pain, so the relevant rules for
# code-generating Perl scripts are hard-coded here.