summaryrefslogtreecommitdiff
path: root/infrastructure
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2015-12-19 00:42:28 +0000
committerChris Wilson <chris+github@qwirx.com>2015-12-19 23:55:29 +0000
commitdbd29ff4a11b517cfe861dfc97d944cd631cb8cd (patch)
tree57cdc1db82428a0181d18941b032c32a0ac2785a /infrastructure
parent07c0c1910b3b960b6a6507b95e6c8bee088597cb (diff)
Add dependencies between modules properly
Diffstat (limited to 'infrastructure')
-rw-r--r--infrastructure/cmake/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index f55f7be2..5f7bd608 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -222,7 +222,7 @@ foreach(module_dep
if(DEBUG)
message(STATUS "add dependency to '${module_name}': '${dependency}'")
endif()
- # add_dependencies(${module_name} ${dependency})
+ add_dependencies(${module_name} ${dependency})
if(dependency MATCHES "^(lib_.*|qdbm)$")
# message(STATUS "add link library to '${module_name}': '${dependency}'")
target_link_libraries(${module_name} PUBLIC ${dependency})