summaryrefslogtreecommitdiff
path: root/infrastructure
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2016-09-02 23:42:42 +0100
committerChris Wilson <chris+github@qwirx.com>2016-08-28 22:09:52 +0100
commit756222dd41fdee629e5dc928f2ddbe3ed524f6ed (patch)
tree564f5f2076f98ebf1d6bb060966e40ea415517fe /infrastructure
parent0d7d50e04c7aac32c9f718e311cfd37685e9c051 (diff)
Use ccache if available in CMake builds.
Diffstat (limited to 'infrastructure')
-rw-r--r--infrastructure/cmake/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index 57de5039..a63f838a 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -1,4 +1,11 @@
cmake_minimum_required(VERSION 2.6)
+
+find_program(CCACHE_PROGRAM ccache)
+if(CCACHE_PROGRAM)
+ # Support Unix Makefiles and Ninja
+ set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCACHE_PROGRAM}")
+endif()
+
project(BoxBackup)
enable_testing()