summaryrefslogtreecommitdiff
path: root/lib/common/BoxPlatform.h
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-01-21 09:35:00 +0000
committerChris Wilson <chris+github@qwirx.com>2008-01-21 09:35:00 +0000
commit945498cdd52d535b0f1840d3dbd866dd581731be (patch)
tree33cad99b4d1bc00898901b323512505a858a986d /lib/common/BoxPlatform.h
parent5034b29c61b0c003dd881ef38385c98623bee6aa (diff)
Fix DIRFD properly
Diffstat (limited to 'lib/common/BoxPlatform.h')
-rw-r--r--lib/common/BoxPlatform.h2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/common/BoxPlatform.h b/lib/common/BoxPlatform.h
index 391df3ea..af595e04 100644
--- a/lib/common/BoxPlatform.h
+++ b/lib/common/BoxPlatform.h
@@ -169,7 +169,7 @@
// We cannot define macros with arguments directly using AC_DEFINE,
// so do it here instead of in configure.ac.
-#if HAVE_DECL_DIRFD
+#if ! HAVE_DECL_DIRFD
#define dirfd(x) (x)->d_fd
#endif