summaryrefslogtreecommitdiff
path: root/lib/common
diff options
context:
space:
mode:
authorMartin Ebourne <martin@ebourne.me.uk>2006-03-04 01:33:46 +0000
committerMartin Ebourne <martin@ebourne.me.uk>2006-03-04 01:33:46 +0000
commitdefac6623afe8b7d765a9477371fbc47da855c19 (patch)
treeb6d5c9e77d896a67ee1d56bc9ffa9d703ae45c81 /lib/common
parent6f868d48446f4196d2ad69e7ca9be42047ea2d5e (diff)
This is part 1 of a patch from James O'Gorman.
configure now detects perl executable location and updates all scripts to use the correct path; also adds PERL_EXECUTABLE define to BoxConfig.h. makebuildenv.pl adds PERL define to all makefiles.
Diffstat (limited to 'lib/common')
-rw-r--r--lib/common/Makefile.extra4
-rwxr-xr-xlib/common/makeexception.pl2
2 files changed, 3 insertions, 3 deletions
diff --git a/lib/common/Makefile.extra b/lib/common/Makefile.extra
index 92e6fbb3..04dd8e71 100644
--- a/lib/common/Makefile.extra
+++ b/lib/common/Makefile.extra
@@ -3,9 +3,9 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_CommonException.h autogen_CommonException.cpp: $(MAKEEXCEPTION) CommonException.txt
- perl $(MAKEEXCEPTION) CommonException.txt
+ $(PERL) $(MAKEEXCEPTION) CommonException.txt
# AUTOGEN SEEDING
autogen_ConversionException.h autogen_ConversionException.cpp: $(MAKEEXCEPTION) ConversionException.txt
- perl $(MAKEEXCEPTION) ConversionException.txt
+ $(PERL) $(MAKEEXCEPTION) ConversionException.txt
diff --git a/lib/common/makeexception.pl b/lib/common/makeexception.pl
index c0388286..1564b75b 100755
--- a/lib/common/makeexception.pl
+++ b/lib/common/makeexception.pl
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!@PERL@
# global exception list file
my $global_list = '../../ExceptionCodes.txt';