summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorAG <contact@grandville.net>2015-10-26 23:18:51 +0100
committerAG <contact@grandville.net>2015-10-26 23:18:51 +0100
commit57198ec30c5678c5a5ed26ef6b345d289bb48e50 (patch)
tree5f51b8068ab38037ab86ce9fcb30e729ca769da9 /lib
parentad1c0240f9ac4c56519cf0e5c2765b7edfc30ca0 (diff)
add specific define to allow the use of std::min and sd::max from windows
Diffstat (limited to 'lib')
-rw-r--r--lib/backupstore/BackupStoreFile.cpp4
-rw-r--r--lib/backupstore/BackupStoreRefCountDatabase.cpp2
-rw-r--r--lib/common/BoxConfig-MSVC.h3
3 files changed, 6 insertions, 3 deletions
diff --git a/lib/backupstore/BackupStoreFile.cpp b/lib/backupstore/BackupStoreFile.cpp
index 5ceefe90..99562685 100644
--- a/lib/backupstore/BackupStoreFile.cpp
+++ b/lib/backupstore/BackupStoreFile.cpp
@@ -304,7 +304,7 @@ void BackupStoreFile::VerifyStream::Write(const void *pBuffer, int NBytes, int T
size_t BytesLeftInCurrentUnit = mCurrentUnitSize -
mCurrentUnitData.GetSize();
// Add however many bytes are needed/available to the current unit's buffer.
- BytesToAdd = min(BytesLeftInCurrentUnit, (size_t)NBytes);
+ BytesToAdd = std::min(BytesLeftInCurrentUnit, (size_t)NBytes);
}
// We must make progress here, or we could have infinite recursion.
@@ -502,7 +502,7 @@ void BackupStoreFile::VerifyStream::Close(bool CloseCopyStream)
CollectInBufferStream* pPreviousBuffer = mCurrentBufferIsAlternate ?
&mCurrentUnitData : &mAlternateData;
- int64_t BytesFromCurrentBuffer = min(mBlockIndexSize,
+ int64_t BytesFromCurrentBuffer = std::min(mBlockIndexSize,
(int64_t)pCurrentBuffer->GetSize());
int64_t BytesFromPreviousBuffer = mBlockIndexSize - BytesFromCurrentBuffer;
diff --git a/lib/backupstore/BackupStoreRefCountDatabase.cpp b/lib/backupstore/BackupStoreRefCountDatabase.cpp
index 24c7b38e..8b51b70a 100644
--- a/lib/backupstore/BackupStoreRefCountDatabase.cpp
+++ b/lib/backupstore/BackupStoreRefCountDatabase.cpp
@@ -346,7 +346,7 @@ int BackupStoreRefCountDatabase::ReportChangesTo(BackupStoreRefCountDatabase& rO
int64_t MaxNewObjectId = GetLastObjectIDUsed();
for (int64_t ObjectID = BACKUPSTORE_ROOT_DIRECTORY_ID;
- ObjectID < max(MaxOldObjectId, MaxNewObjectId);
+ ObjectID < std::max(MaxOldObjectId, MaxNewObjectId);
ObjectID++)
{
typedef BackupStoreRefCountDatabase::refcount_t refcount_t;
diff --git a/lib/common/BoxConfig-MSVC.h b/lib/common/BoxConfig-MSVC.h
index eeb25d2e..82ab4997 100644
--- a/lib/common/BoxConfig-MSVC.h
+++ b/lib/common/BoxConfig-MSVC.h
@@ -2,6 +2,9 @@
/* lib/common/BoxConfig.h.in. Generated from configure.ac by autoheader. */
/* Hacked by hand to work for MSVC by Chris Wilson */
+// using std::min/max
+#define NOMINMAX
+
/* Define to major version for BDB_VERSION */
/* #undef BDB_VERSION_MAJOR */