summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2007-12-15 17:02:55 +0000
committerChris Wilson <chris+github@qwirx.com>2007-12-15 17:02:55 +0000
commitd83236f4931ad0184d663ff91e411c071a3304c8 (patch)
tree4b9f7e28987d0ea713ba5682bea25be5ffe43b83 /lib
parentf524e66226c1bab18406542d61d6a5f19caa58f2 (diff)
Fix definition of dirfd(x) macro (autoconf doesn't like defining macros
with parameters).
Diffstat (limited to 'lib')
-rw-r--r--lib/common/BoxPlatform.h8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/common/BoxPlatform.h b/lib/common/BoxPlatform.h
index 4b58d31d..a3d0e7ad 100644
--- a/lib/common/BoxPlatform.h
+++ b/lib/common/BoxPlatform.h
@@ -165,4 +165,12 @@
#include "emu.h"
#endif
+// Solaris has no dirfd(x) macro or function, and we need one.
+// We cannot define macros with arguments directly using AC_DEFINE,
+// so do it here instead of in configure.ac.
+
+#ifndef HAVE_DECL_DIRFD
+ #define dirfd(x) (x)->d_fd
+#endif
+
#endif // BOXPLATFORM__H