summaryrefslogtreecommitdiff
path: root/patches
diff options
context:
space:
mode:
authorAndreas Beckmann <anbe@debian.org>2017-01-21 21:29:52 -0500
committerAndreas Beckmann <anbe@debian.org>2017-01-21 21:29:52 -0500
commitc2d8fdb71c9dcdc367bc682f21fc86164e8fa33b (patch)
treecaf8d19c3e7d3f94110ab43e6a890d6f83799604 /patches
Import boxbackup_0.11.1~r2837-4.debian.tar.xz
[dgit import tarball boxbackup 0.11.1~r2837-4 boxbackup_0.11.1~r2837-4.debian.tar.xz]
Diffstat (limited to 'patches')
-rw-r--r--patches/03-adjust-syslog-facility.diff50
-rw-r--r--patches/05-dont_use_net_for_docs.diff12
-rw-r--r--patches/06-gcc_4.4_fixes.diff17
-rw-r--r--patches/series3
4 files changed, 82 insertions, 0 deletions
diff --git a/patches/03-adjust-syslog-facility.diff b/patches/03-adjust-syslog-facility.diff
new file mode 100644
index 00000000..e3033573
--- /dev/null
+++ b/patches/03-adjust-syslog-facility.diff
@@ -0,0 +1,50 @@
+change default syslog facility from LOG_LOCAL6 to LOG_DAEMON
+
+--- a/bin/bbstored/BackupStoreDaemon.cpp
++++ b/bin/bbstored/BackupStoreDaemon.cpp
+@@ -203,7 +203,7 @@ void BackupStoreDaemon::Run()
+ SetProcessTitle("housekeeping, idle");
+ whichSocket = 1;
+ // Change the log name
+- ::openlog("bbstored/hk", LOG_PID, LOG_LOCAL6);
++ ::openlog("bbstored/hk", LOG_PID, LOG_DAEMON);
+ // Log that housekeeping started
+ BOX_INFO("Housekeeping process started");
+ // Ignore term and hup
+--- a/lib/common/Logging.cpp
++++ b/lib/common/Logging.cpp
+@@ -401,7 +401,7 @@ bool Syslog::Log(Log::Level level, const
+ return true;
+ }
+
+-Syslog::Syslog() : mFacility(LOG_LOCAL6)
++Syslog::Syslog() : mFacility(LOG_DAEMON)
+ {
+ ::openlog("Box Backup", LOG_PID, mFacility);
+ }
+@@ -439,8 +439,8 @@ int Syslog::GetNamedFacility(const std::
+ #undef CASE_RETURN
+
+ BOX_ERROR("Unknown log facility '" << rFacility << "', "
+- "using default LOCAL6");
+- return LOG_LOCAL6;
++ "using default DAEMON");
++ return LOG_DAEMON;
+ }
+
+ bool FileLogger::Log(Log::Level Level, const std::string& rFile,
+--- a/docs/docbook/adminguide.xml
++++ b/docs/docbook/adminguide.xml
+@@ -286,6 +286,12 @@ local5.info /var
+ <para><emphasis role="bold">Note:</emphasis> Separators must be tabs,
+ otherwise these entries will be ignored.</para>
+
++ <para><emphasis role="bold">Note2:</emphasis> The packaged
++ debian and ubuntu versions of boxbackup do not log to local6,
++ but to the more standard 'daemon' facility. This means you
++ should not have anything to do to your syslog configuration,
++ since it is configured to be logged by default.</para>
++
+ <programlisting>touch /var/log/box
+ touch /var/log/raidfile</programlisting>
+
diff --git a/patches/05-dont_use_net_for_docs.diff b/patches/05-dont_use_net_for_docs.diff
new file mode 100644
index 00000000..71cb6c25
--- /dev/null
+++ b/patches/05-dont_use_net_for_docs.diff
@@ -0,0 +1,12 @@
+=== modified file 'docs/Makefile'
+--- a/docs/Makefile
++++ b/docs/Makefile
+@@ -10,7 +10,7 @@
+
+ all: docs
+
+-DBPROC_COMMAND = xsltproc
++DBPROC_COMMAND = xsltproc --nonet
+ MKDIR_COMMAND = mkdir
+ CP_COMMAND = cp
+ PERL_COMMAND = perl
diff --git a/patches/06-gcc_4.4_fixes.diff b/patches/06-gcc_4.4_fixes.diff
new file mode 100644
index 00000000..46ec64cf
--- /dev/null
+++ b/patches/06-gcc_4.4_fixes.diff
@@ -0,0 +1,17 @@
+references:
+
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=526152
+https://bugs.launchpad.net/bugs/371809
+
+Impact: FTBFS with gcc 4.4
+
+=== modified file 'lib/server/ServerControl.cpp'
+--- a/lib/server/ServerControl.cpp
++++ b/lib/server/ServerControl.cpp
+@@ -1,5 +1,6 @@
+ #include "Box.h"
+
++#include <stdio.h>
+ #include <errno.h>
+ #include <stdio.h>
+
diff --git a/patches/series b/patches/series
new file mode 100644
index 00000000..ab768cfb
--- /dev/null
+++ b/patches/series
@@ -0,0 +1,3 @@
+03-adjust-syslog-facility.diff
+05-dont_use_net_for_docs.diff
+06-gcc_4.4_fixes.diff