summaryrefslogtreecommitdiff
path: root/test/backupstorepatch
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2006-01-28 00:13:44 +0000
committerChris Wilson <chris+github@qwirx.com>2006-01-28 00:13:44 +0000
commit9e025fd0ea42782e93363958804c6e2437b44a30 (patch)
treefd37208fa3f569067e75ea24765c575d9884b339 /test/backupstorepatch
parent41f02c67b06ae838dc9fc8829741ed51abfe5b42 (diff)
* configure.ac
* bin/bbstored/backupprotocol.txt * bin/bbstored/BackupCommands.cpp * bin/bbackupd/BackupClientContext.cpp * bin/bbackupd/BackupClientContext.h * bin/bbackupd/BackupClientDirectoryRecord.cpp * bin/bbackupd/BackupDaemon.cpp * lib/backupclient/BackupStoreFileDiff.cpp * lib/backupclient/BackupDaemonConfigVerify.cpp * lib/backupclient/BackupStoreFile.h * test/backupstore/testbackupstore.cpp * test/backupstorepatch/testbackupstorepatch.cpp - Applied changes from chris/diff-timeout-and-ssl-keepalive * test/backupdiff/testbackupdiff.cpp - Fixed test to match new prototype for EncodeFileDiff
Diffstat (limited to 'test/backupstorepatch')
-rw-r--r--test/backupstorepatch/testbackupstorepatch.cpp13
1 files changed, 10 insertions, 3 deletions
diff --git a/test/backupstorepatch/testbackupstorepatch.cpp b/test/backupstorepatch/testbackupstorepatch.cpp
index a4a1ece3..5d77c3fd 100644
--- a/test/backupstorepatch/testbackupstorepatch.cpp
+++ b/test/backupstorepatch/testbackupstorepatch.cpp
@@ -376,10 +376,17 @@ int test(int argc, const char *argv[])
char filename[64];
::sprintf(filename, "testfiles/%d.test", f);
bool isCompletelyDifferent = false;
- std::auto_ptr<IOStream> patchStream(BackupStoreFile::EncodeFileDiff(filename,
+ std::auto_ptr<IOStream> patchStream(
+ BackupStoreFile::EncodeFileDiff(
+ filename,
BackupProtocolClientListDirectory::RootDirectory, /* containing directory */
- storeFilename, diffFromID, *blockIndexStream,
- protocol.GetTimeout(), 0 /* not interested in the modification time */, &isCompletelyDifferent));
+ storeFilename,
+ diffFromID,
+ *blockIndexStream,
+ protocol.GetTimeout(),
+ NULL, // DiffTimer impl
+ 0 /* not interested in the modification time */,
+ &isCompletelyDifferent));
// Upload the patch to the store
std::auto_ptr<BackupProtocolClientSuccess> stored(protocol.QueryStoreFile(