summaryrefslogtreecommitdiff
path: root/test/basicserver/Makefile.extra
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2011-08-27 14:06:46 +0000
committerChris Wilson <chris+github@qwirx.com>2011-08-27 14:06:46 +0000
commita473bb0923b0f7800bb95ef96ba20f5cf6cbe5b4 (patch)
tree68620eb4a0566889c5a2e903a5b2fb0b678d9613 /test/basicserver/Makefile.extra
parent50aac86024fae12072a240e6b952c9bb11437956 (diff)
Combine client and server protocols to make way for an offline/local protocol.
Rename ProtocolObject to Message.
Diffstat (limited to 'test/basicserver/Makefile.extra')
-rw-r--r--test/basicserver/Makefile.extra17
1 files changed, 4 insertions, 13 deletions
diff --git a/test/basicserver/Makefile.extra b/test/basicserver/Makefile.extra
index 50120136..e6a4675e 100644
--- a/test/basicserver/Makefile.extra
+++ b/test/basicserver/Makefile.extra
@@ -1,21 +1,12 @@
MAKEPROTOCOL = ../../lib/server/makeprotocol.pl
-GEN_CMD_SRV = $(MAKEPROTOCOL) Server testprotocol.txt
-GEN_CMD_CLI = $(MAKEPROTOCOL) Client testprotocol.txt
+GEN_CMD = $(MAKEPROTOCOL) testprotocol.txt
# AUTOGEN SEEDING
-autogen_TestProtocolServer.cpp: $(MAKEPROTOCOL) testprotocol.txt
- $(_PERL) $(GEN_CMD_SRV)
+autogen_TestProtocol.cpp: $(MAKEPROTOCOL) testprotocol.txt
+ $(_PERL) $(GEN_CMD)
autogen_TestProtocolServer.h: $(MAKEPROTOCOL) testprotocol.txt
- $(_PERL) $(GEN_CMD_SRV)
-
-
-# AUTOGEN SEEDING
-autogen_TestProtocolClient.cpp: $(MAKEPROTOCOL) testprotocol.txt
- $(_PERL) $(GEN_CMD_CLI)
-
-autogen_TestProtocolClient.h: $(MAKEPROTOCOL) testprotocol.txt
- $(_PERL) $(GEN_CMD_CLI)
+ $(_PERL) $(GEN_CMD)