summaryrefslogtreecommitdiff
path: root/test/basicserver/Makefile.extra
diff options
context:
space:
mode:
authorMartin Ebourne <martin@ebourne.me.uk>2006-03-04 01:33:46 +0000
committerMartin Ebourne <martin@ebourne.me.uk>2006-03-04 01:33:46 +0000
commitdefac6623afe8b7d765a9477371fbc47da855c19 (patch)
treeb6d5c9e77d896a67ee1d56bc9ffa9d703ae45c81 /test/basicserver/Makefile.extra
parent6f868d48446f4196d2ad69e7ca9be42047ea2d5e (diff)
This is part 1 of a patch from James O'Gorman.
configure now detects perl executable location and updates all scripts to use the correct path; also adds PERL_EXECUTABLE define to BoxConfig.h. makebuildenv.pl adds PERL define to all makefiles.
Diffstat (limited to 'test/basicserver/Makefile.extra')
-rw-r--r--test/basicserver/Makefile.extra8
1 files changed, 4 insertions, 4 deletions
diff --git a/test/basicserver/Makefile.extra b/test/basicserver/Makefile.extra
index 51280db9..3feda961 100644
--- a/test/basicserver/Makefile.extra
+++ b/test/basicserver/Makefile.extra
@@ -6,16 +6,16 @@ GEN_CMD_CLI = $(MAKEPROTOCOL) Client testprotocol.txt
# AUTOGEN SEEDING
autogen_TestProtocolServer.cpp: $(MAKEPROTOCOL) testprotocol.txt
- perl $(GEN_CMD_SRV)
+ $(PERL) $(GEN_CMD_SRV)
autogen_TestProtocolServer.h: $(MAKEPROTOCOL) testprotocol.txt
- perl $(GEN_CMD_SRV)
+ $(PERL) $(GEN_CMD_SRV)
# AUTOGEN SEEDING
autogen_TestProtocolClient.cpp: $(MAKEPROTOCOL) testprotocol.txt
- perl $(GEN_CMD_CLI)
+ $(PERL) $(GEN_CMD_CLI)
autogen_TestProtocolClient.h: $(MAKEPROTOCOL) testprotocol.txt
- perl $(GEN_CMD_CLI)
+ $(PERL) $(GEN_CMD_CLI)