summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rw-r--r--lib/common/StreamableMemBlock.cpp12
-rw-r--r--lib/common/WaitForEvent.cpp4
3 files changed, 9 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index c3aff9cb..e81f85cd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,7 +4,7 @@ boxbackup (0.11~rc2-5) unstable; urgency=low
<dktrkranz@ubuntu.com> for reporting. Closes: #507973
* Add missing #includes in lib/common/Logging.cpp and
lib/common/DebugMemLeakFinder.cpp. Also use malloc, free, etc from the
- namespace std:: instead of the global namespace
+ namespace std:: instead of the global namespace in several other files
Closes: #505696, #512510
-- Reinhard Tartler <siretart@tauware.de> Thu, 22 Jan 2009 08:26:24 +0100
diff --git a/lib/common/StreamableMemBlock.cpp b/lib/common/StreamableMemBlock.cpp
index cf5d5316..58cf4043 100644
--- a/lib/common/StreamableMemBlock.cpp
+++ b/lib/common/StreamableMemBlock.cpp
@@ -49,7 +49,7 @@
#include "Box.h"
#include <new>
-#include <stdlib.h>
+#include <cstdlib>
#include <string.h>
#include "StreamableMemBlock.h"
@@ -173,7 +173,7 @@ void StreamableMemBlock::Set(IOStream &rStream, int Timeout)
}
catch(...)
{
- ::free(pblock);
+ std::free(pblock);
throw;
}
@@ -224,7 +224,7 @@ void StreamableMemBlock::FreeBlock()
{
if(mpBuffer != 0)
{
- ::free(mpBuffer);
+ std::free(mpBuffer);
}
mpBuffer = 0;
mSize = 0;
@@ -244,7 +244,7 @@ void StreamableMemBlock::AllocateBlock(int Size)
ASSERT(mpBuffer == 0);
if(Size > 0)
{
- mpBuffer = ::malloc(Size);
+ mpBuffer = std::malloc(Size);
if(mpBuffer == 0)
{
throw std::bad_alloc();
@@ -267,7 +267,7 @@ void StreamableMemBlock::ResizeBlock(int Size)
ASSERT(Size > 0);
if(Size > 0)
{
- void *pnewBuffer = ::realloc(mpBuffer, Size);
+ void *pnewBuffer = std::realloc(mpBuffer, Size);
if(pnewBuffer == 0)
{
throw std::bad_alloc();
@@ -318,7 +318,7 @@ void StreamableMemBlock::ReadFromStream(IOStream &rStream, int Timeout)
}
catch(...)
{
- ::free(pblock);
+ std::free(pblock);
throw;
}
diff --git a/lib/common/WaitForEvent.cpp b/lib/common/WaitForEvent.cpp
index 1f3a67d0..f922fe86 100644
--- a/lib/common/WaitForEvent.cpp
+++ b/lib/common/WaitForEvent.cpp
@@ -104,7 +104,7 @@ WaitForEvent::~WaitForEvent()
#else
if(mpPollInfo != 0)
{
- ::free(mpPollInfo);
+ std::free(mpPollInfo);
mpPollInfo = 0;
}
#endif
@@ -180,7 +180,7 @@ void *WaitForEvent::Wait()
if(mpPollInfo == 0)
{
// Yes...
- mpPollInfo = (struct pollfd *)::malloc((sizeof(struct pollfd) * mItems.size()) + 4);
+ mpPollInfo = (struct pollfd *)std::malloc((sizeof(struct pollfd) * mItems.size()) + 4);
if(mpPollInfo == 0)
{
throw std::bad_alloc();