summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/boxbackup-client.postinst8
-rw-r--r--debian/boxbackup-server.config2
-rw-r--r--debian/boxbackup-server.postinst2
-rw-r--r--debian/changelog7
4 files changed, 13 insertions, 6 deletions
diff --git a/debian/boxbackup-client.postinst b/debian/boxbackup-client.postinst
index e21db03a..249e1e9e 100644
--- a/debian/boxbackup-client.postinst
+++ b/debian/boxbackup-client.postinst
@@ -74,15 +74,15 @@ __EOF
if [ "$RET" = "lazy" ]; then
db_get boxbackup-client/UpdateStoreInterval
UPDATE=$RET
- [ -z $UPDATE ] && UPDATE="3600"
+ [ -z "$UPDATE" ] && UPDATE="3600"
db_get boxbackup-client/MinimumFileAge
FILEAGE=$RET
- [ -z $FILEAGE ] && FILEAGE="21600"
+ [ -z "$FILEAGE" ] && FILEAGE="21600"
db_get boxbackup-client/MaxUploadWait
UPWAIT=$RET
- [ -z $UPWAIT ] && UPWAIT="86400"
+ [ -z "$UPWAIT" ] && UPWAIT="86400"
AUTO=yes
else
@@ -219,7 +219,7 @@ __EOF
chmod 600 $BBKEY || true
# SSL stuff
- if [ ! -z $ACCOUNT ]; then
+ if [ ! -z "$ACCOUNT" ]; then
if [ ! -e $BBPRIVKEY -a ! -e $BBCERT ]; then
db_get boxbackup-client/generateCertificate
diff --git a/debian/boxbackup-server.config b/debian/boxbackup-server.config
index d0ed5a6f..36546f88 100644
--- a/debian/boxbackup-server.config
+++ b/debian/boxbackup-server.config
@@ -33,7 +33,7 @@ while [ $RAIDOK = 0 ]; do
DIR3=`echo "$RET" | awk '{ print $3 }'`
if [ -n $DIR1 ]; then
- if [ -z $DIR2 -o -z $DIR3 ]; then
+ if [ -z "$DIR2" -o -z "$DIR3" ]; then
DIR2=$DIR1
DIR3=$DIR1
fi
diff --git a/debian/boxbackup-server.postinst b/debian/boxbackup-server.postinst
index 95ceb542..4045daca 100644
--- a/debian/boxbackup-server.postinst
+++ b/debian/boxbackup-server.postinst
@@ -71,7 +71,7 @@ case "$1" in
DIR3=`echo "$RET" | awk '{ print $3 }'`
if [ -n $DIR1 ]; then
- if [ -z $DIR2 -o -z $DIR3 ]; then
+ if [ -z "$DIR2" -o -z "$DIR3" ]; then
DIR2=$DIR1
DIR3=$DIR1
fi
diff --git a/debian/changelog b/debian/changelog
index e81f85cd..264981f2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+boxbackup (0.11~rc2-6) unstable; urgency=low
+
+ * Fix shell scripting in the debconf interaction code of the package's
+ postinst script. This should prevent problems like LP: #222999
+
+ -- Reinhard Tartler <siretart@tauware.de> Wed, 11 Feb 2009 08:55:05 +0100
+
boxbackup (0.11~rc2-5) unstable; urgency=low
* Bugfix: "Please build-depend on docbook-xml". Thanks to Luca Falavigna