summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lib/common/BoxPlatform.h8
-rw-r--r--lib/common/FileStream.h8
2 files changed, 8 insertions, 8 deletions
diff --git a/lib/common/BoxPlatform.h b/lib/common/BoxPlatform.h
index c625a7c7..617aa031 100644
--- a/lib/common/BoxPlatform.h
+++ b/lib/common/BoxPlatform.h
@@ -176,6 +176,14 @@
#include "emu.h"
+#ifdef WIN32
+ #define INVALID_FILE INVALID_HANDLE_VALUE
+ typedef HANDLE tOSFileHandle;
+#else
+ #define INVALID_FILE -1
+ typedef int tOSFileHandle;
+#endif
+
// Solaris has no dirfd(x) macro or function, and we need one for
// intercept tests. We cannot define macros with arguments directly
// using AC_DEFINE, so do it here instead of in configure.ac.
diff --git a/lib/common/FileStream.h b/lib/common/FileStream.h
index 7c4118cd..9101a968 100644
--- a/lib/common/FileStream.h
+++ b/lib/common/FileStream.h
@@ -20,14 +20,6 @@
#include <unistd.h>
#endif
-#ifdef WIN32
- #define INVALID_FILE INVALID_HANDLE_VALUE
- typedef HANDLE tOSFileHandle;
-#else
- #define INVALID_FILE -1
- typedef int tOSFileHandle;
-#endif
-
class FileStream : public IOStream
{
public: