summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac12
-rw-r--r--infrastructure/BoxPlatform.pm.in10
2 files changed, 17 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 4f2c7ea5..4239b821 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,6 +175,18 @@ if test "x$enable_static_bin" = "xyes"; then
LIBS="-Wl,-Bstatic $LIBS -Wl,-Bdynamic"
fi
+## Kludge to allow makeparcels.pl to use bindir. This is not a good long term
+## solution because it prevents use of "make exec_prefix=/some/dir"
+saved_prefix=$prefix
+saved_exec_prefix=$exec_prefix
+test "x$prefix" = xNONE && prefix=$ac_default_prefix
+test "x$exec_prefix" = xNONE && exec_prefix='${prefix}'
+bindir_expanded=`eval "echo $bindir"`
+bindir_expanded=`eval "echo $bindir_expanded"`
+prefix=$saved_prefix
+exec_prefix=$saved_exec_prefix
+AC_SUBST([bindir_expanded])
+
### Output files
AC_CONFIG_FILES([infrastructure/BoxPlatform.pm])
diff --git a/infrastructure/BoxPlatform.pm.in b/infrastructure/BoxPlatform.pm.in
index 10fbe7cd..9567d585 100644
--- a/infrastructure/BoxPlatform.pm.in
+++ b/infrastructure/BoxPlatform.pm.in
@@ -13,8 +13,8 @@ BEGIN
chomp $build_cpu;
# Cygwin Builds usually something like CYGWIN_NT-5.0, CYGWIN_NT-5.1
# Box Backup tried on Win2000,XP only :)
-
- $build_os = 'CYGWIN' if $build_os =~ m/CYGWIN/;
+
+ $build_os = 'CYGWIN' if $build_os =~ m/CYGWIN/;
$make_command = ($build_os eq 'Darwin') ? 'bsdmake' : ($build_os eq 'SunOS') ? 'gmake' : 'make';
$bsd_make = ($build_os ne 'Linux' && $build_os ne 'CYGWIN' && $build_os ne "SunOS");
@@ -34,10 +34,10 @@ BEGIN
$product_name = <VERSION>;
chomp $product_name;
close VERSION;
-
+
# where to put the files
- $install_into_dir = '@bindir@';
-
+ $install_into_dir = '@bindir_expanded@';
+
# if it's Darwin,
if($build_os eq 'Darwin')
{