summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac2
-rwxr-xr-xinfrastructure/makebuildenv.pl.in6
2 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index dff3f9e5..441a869f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -403,7 +403,7 @@ cat parcels.txt | sed -e 's/#.*//' | while read cmd subdir configure_args; do
done || exit $?
# Write summary of important info
-cat | tee config.log.features <<EOC
+tee config.log.features <<EOC
A summary of the build configuration is below. Box Backup will function
without these features, but will work better where they are present. Refer
to the documentation for more information on each feature.
diff --git a/infrastructure/makebuildenv.pl.in b/infrastructure/makebuildenv.pl.in
index f165accc..93115514 100755
--- a/infrastructure/makebuildenv.pl.in
+++ b/infrastructure/makebuildenv.pl.in
@@ -98,7 +98,11 @@ while(<FINDAUTOGEN>)
}
# run command
- die "Couldn't run command $c" unless (0 == system("(cd $dir; $c)"))
+ unless (0 == system("(cd $dir; $c)"))
+ {
+ die "Couldn't run command $c " .
+ "(in $dir) for $file";
+ }
}
}
}