summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--infrastructure/cmake/CMakeLists.txt2
-rwxr-xr-xruntest.pl.in4
2 files changed, 3 insertions, 3 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index 6dedf429..a9bd549f 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -200,7 +200,7 @@ foreach(module_dep
"${module_path}/_main.cpp")
add_test(NAME ${test_name}
COMMAND ${PERL_EXECUTABLE} ${base_dir}/runtest.pl.in ${test_name}
- $<CONFIG>)
+ $<CONFIG> WORKING_DIRECTORY ${base_dir})
elseif(module_name MATCHES "^(lib_.*|qdbm)$")
if(DEBUG)
message(STATUS "add library '${module_name}': '${module_files}'")
diff --git a/runtest.pl.in b/runtest.pl.in
index 8d7b33b6..2ab60963 100755
--- a/runtest.pl.in
+++ b/runtest.pl.in
@@ -126,9 +126,9 @@ sub runtest
my @commands = (
"msbuild /nologo $quiet ".
- "infrastructure\\cmake\\INSTALL.vcxproj",
+ "infrastructure\\cmake\\build\\INSTALL.vcxproj",
"xcopy /s /i /y /q $test_src_dir $test_dst_dir",
- "copy infrastructure\\cmake\\$test_mode\\$test_project_exe.exe $test_dst_dir"
+ "copy infrastructure\\cmake\\build\\$test_mode\\$test_project_exe.exe $test_dst_dir"
);
if(-d $test_dst_dir)