summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bbackupd/bbackupd-config2
-rw-r--r--bin/bbackupquery/Makefile.extra2
-rwxr-xr-xbin/bbackupquery/makedocumentation.pl2
-rw-r--r--bin/bbstored/Makefile.extra2
-rwxr-xr-xbin/bbstored/bbstored-certs2
-rwxr-xr-xbin/bbstored/bbstored-config2
6 files changed, 6 insertions, 6 deletions
diff --git a/bin/bbackupd/bbackupd-config b/bin/bbackupd/bbackupd-config
index 0d8dd4d1..c06b818d 100755
--- a/bin/bbackupd/bbackupd-config
+++ b/bin/bbackupd/bbackupd-config
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!@PERL@
use strict;
# should be running as root
diff --git a/bin/bbackupquery/Makefile.extra b/bin/bbackupquery/Makefile.extra
index 633ec0fc..f347c451 100644
--- a/bin/bbackupquery/Makefile.extra
+++ b/bin/bbackupquery/Makefile.extra
@@ -1,6 +1,6 @@
# AUTOGEN SEEDING
autogen_Documentation.cpp: makedocumentation.pl documentation.txt
- perl makedocumentation.pl
+ $(PERL) makedocumentation.pl
diff --git a/bin/bbackupquery/makedocumentation.pl b/bin/bbackupquery/makedocumentation.pl
index a3632848..72e45a67 100755
--- a/bin/bbackupquery/makedocumentation.pl
+++ b/bin/bbackupquery/makedocumentation.pl
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!@PERL@
use strict;
print "Creating built-in documentation for bbackupquery...\n";
diff --git a/bin/bbstored/Makefile.extra b/bin/bbstored/Makefile.extra
index 187d53ef..94bc3fb9 100644
--- a/bin/bbstored/Makefile.extra
+++ b/bin/bbstored/Makefile.extra
@@ -5,5 +5,5 @@ GEN_CMD_SRV = $(MAKEPROTOCOL) Server backupprotocol.txt
# AUTOGEN SEEDING
autogen_BackupProtocolServer.cpp autogen_BackupProtocolServer.h: $(MAKEPROTOCOL) backupprotocol.txt
- perl $(GEN_CMD_SRV)
+ $(PERL) $(GEN_CMD_SRV)
diff --git a/bin/bbstored/bbstored-certs b/bin/bbstored/bbstored-certs
index d1fa8dea..e0554d94 100755
--- a/bin/bbstored/bbstored-certs
+++ b/bin/bbstored/bbstored-certs
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!@PERL@
use strict;
# validity period for root certificates -- default is a very long time
diff --git a/bin/bbstored/bbstored-config b/bin/bbstored/bbstored-config
index 0032f4c6..7bd79716 100755
--- a/bin/bbstored/bbstored-config
+++ b/bin/bbstored/bbstored-config
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!@PERL@
use strict;
# should be running as root