summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e171d4ad..98784cf5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,7 @@ test -s install-sh || rm install-sh
### Checks for programs.
AC_LANG([C++])
+AC_PROG_CC
AC_PROG_CXX
AC_CXX_EXCEPTIONS
AC_CXX_NAMESPACES
@@ -382,6 +383,19 @@ if ! $PERL ./infrastructure/makebuildenv.pl \
exit 1
fi
+cat parcels.txt | sed -e 's/#.*//' | while read cmd subdir configure_args; do
+ if test "$cmd" = "subdir"; then
+ echo
+ echo "Configuring $subdir..."
+ cd $subdir
+ export CC CXX CXXFLAGS LDFLAGS LIBS
+ if ! ./configure $configure_args; then
+ echo "Configuring $subdir failed!" >&2
+ exit 1
+ fi
+ fi
+done || exit $?
+
# Write summary of important info
cat <<EOC
A summary of the build configuration is below. Box Backup will function