summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules152
1 files changed, 0 insertions, 152 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 7dec776e..00000000
--- a/debian/rules
+++ /dev/null
@@ -1,152 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 by Joey Hess.
-#
-# This version is for a hypothetical package that builds an
-# architecture-dependant package, as well as an architecture-independent
-# package.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=4
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-TMP:=$(CURDIR)/debian/tmp
-
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -g
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- # Add here commands to configure the package.
- ./configure
-
- touch configure-stamp
-
-build-stamp: configure-stamp
- dh_testdir
-
- # Add here command to compile/build the package.
- $(MAKE)
-
- touch build-stamp
-
-build: build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- rm -f configure-stamp
- rm -f debian/files
-
- find . -name '*.o' | xargs --no-run-if-empty rm
- find . -name '*.a' | xargs --no-run-if-empty rm
- find . -name 'autogen_*' | xargs --no-run-if-empty rm
- find . -name '_*' | xargs --no-run-if-empty rm
- rm -f release/bin/bbstored/bbstored
- rm -f release/bin/bbstoreaccounts/bbstoreaccounts
- rm -f release/bin/bbackupd/bbackupd
- rm -f release/bin/bbackupquery/bbackupquery
- rm -f release/bin/bbackupctl/bbackupctl
- rm -f local/modules.h
- rm -f local/install.msg
- rm -f ExceptionCodes.txt
- rm -f parcels/scripts/install-backup-client
- rm -f parcels/scripts/install-backup-server
- rm -f infrastructure/BoxPlatform.pm
- rm -f lib/common/BoxConfig.h
- rm -f config.log config.status
-
- # Add here commands to clean up after the build process.
- -$(MAKE) clean
-
- find . -name 'Makefile' | xargs --no-run-if-empty rm
-
- dh_clean
-
-install: DH_OPTIONS=
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- mkdir -p $(TMP)/etc/logcheck/ignore.d.workstation
- mkdir -p $(TMP)/etc/logcheck/ignore.d.server
- install -m 644 debian/boxbackup-server.logcheck.ignore $(TMP)/etc/logcheck/ignore.d.workstation/boxbackup-server
- install -m 644 debian/boxbackup-server.logcheck.ignore $(TMP)/etc/logcheck/ignore.d.server/boxbackup-server
-
- dh_install
-
-# Build architecture-independent files here.
-# Pass -i to all debhelper commands in this target to reduce clutter.
-binary-indep: build install
- dh_testdir -i
- dh_testroot -i
-# dh_installdebconf -i
- dh_installdocs -i
-# dh_installexamples -i
-# dh_installmenu -i
-# dh_installlogrotate -i
-# dh_installemacsen -i
-# dh_installpam -i
-# dh_installmime -i
-# dh_installinit -i
-# dh_installcron -i
-# dh_installman -i
-# dh_installinfo -i
-# dh_undocumented -i
- dh_installchangelogs -i
-# dh_link -i
- dh_compress -i
- dh_fixperms -i
- dh_installdeb -i
-# dh_perl -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir -a
- dh_testroot -a
- dh_installdebconf -a
- dh_installdocs -a
-# dh_installexamples -a
-# dh_installmenu -a
-# dh_installlogrotate -a
-# dh_installemacsen -a
-# dh_installpam -a
-# dh_installmime -a
- dh_installinit -a
- dh_installcron -a
- dh_installman
-# dh_installinfo -a
-# dh_undocumented -a
- dh_installchangelogs -a
- dh_strip -a
-# dh_link -a
- dh_compress -a
- dh_fixperms -a
-# dh_makeshlibs -a
- dh_installdeb -a
-# dh_perl -a
- dh_shlibdeps -a
- dh_gencontrol -a
- dh_md5sums -a
- dh_builddeb -a
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install