summaryrefslogtreecommitdiff
path: root/distribution
diff options
context:
space:
mode:
Diffstat (limited to 'distribution')
-rw-r--r--distribution/boxbackup/contrib/cygwin/README.txt30
-rwxr-xr-xdistribution/boxbackup/contrib/cygwin/install-cygwin-service.pl.in112
-rwxr-xr-xdistribution/boxbackup/contrib/cygwin/remove-cygwin-service.sh14
-rw-r--r--distribution/boxbackup/contrib/debian/README.txt9
-rw-r--r--distribution/boxbackup/contrib/debian/bbackupd38
-rw-r--r--distribution/boxbackup/contrib/debian/bbstored38
-rw-r--r--distribution/boxbackup/contrib/redhat/README.txt7
-rw-r--r--distribution/boxbackup/contrib/redhat/bbackupd83
-rw-r--r--distribution/boxbackup/contrib/redhat/bbstored83
-rw-r--r--distribution/boxbackup/contrib/rpm/README.txt16
-rw-r--r--distribution/boxbackup/contrib/rpm/boxbackup.spec240
-rw-r--r--distribution/boxbackup/contrib/suse/README.txt5
-rw-r--r--distribution/boxbackup/contrib/suse/bbackupd101
-rw-r--r--distribution/boxbackup/contrib/suse/bbstored103
14 files changed, 0 insertions, 879 deletions
diff --git a/distribution/boxbackup/contrib/cygwin/README.txt b/distribution/boxbackup/contrib/cygwin/README.txt
deleted file mode 100644
index 83f32fd9..00000000
--- a/distribution/boxbackup/contrib/cygwin/README.txt
+++ /dev/null
@@ -1,30 +0,0 @@
- Making boxbackup run as a Windows Service
-
-For most installations (with the default locations for config files,
-etc.) running the install-cygwin-service.pl script will complete the
-installation painlessly, and you will have a running bbackupd after
-completing the installation, and whenever you reboot.
-
-Simply run the script:
-
-perl install-cygwin-service.pl
-
-The service can be monitored in the Windows Service Manager. It is named
-boxbackup.
-
-For non-standard configurations, there are command-line options to point
-the script to the bbackupd.conf config file, and the bbackupd.exe
-executable:
-
-perl install-cygwin-service.pl [-c <path-to-bbackupd-config-file>] [-e
-<path-to-bbackupd-executable-file>]
-
-
- Removing the Service
-
-If you decide not to run backups on a machine anymore, simply remove the
-service by running:
-
-sh remove-cygwin-service.sh
-
-
diff --git a/distribution/boxbackup/contrib/cygwin/install-cygwin-service.pl.in b/distribution/boxbackup/contrib/cygwin/install-cygwin-service.pl.in
deleted file mode 100755
index a580e99c..00000000
--- a/distribution/boxbackup/contrib/cygwin/install-cygwin-service.pl.in
+++ /dev/null
@@ -1,112 +0,0 @@
-#!@PERL@ -w
-
-
-# Contributed to the boxbackup project by Per Reedtz Thomsen. pthomsen@reedtz.com
-
-# This script reads the config file for boxbackup, and changes the mode
-# of the directory named by 'DataDirectory' and any files there. Also,
-# the files pointed to by the 'CommandSocket' and 'PidFile' configuration
-# parameters will be chmod'ed to be read-write by all.
-# The Windows services are created and started using the 'cygrunsrv' utility.
-
-# Date Who Comments
-# 20041005 pthomsen@reedtz.com Created
-# 20041020 pthomsen@reedtz.com Switched to using Getopt::Std for cmd-line things.
-
-use strict;
-
-use Getopt::Std;
-getopt('ce');
-our ($opt_c, $opt_e);
-# Figure out the config file to use. Default is /etc/box/bbackupd.conf
-my $confFile = (defined($opt_c) ? $opt_c : "/etc/box/bbackupd.conf");
-# Figure out the bbaackupd executable to use. Default is /usr/local/bin/bbackupd.exe
-my $exeFile = (defined($opt_e) ? $opt_e : "/usr/local/bin/bbackupd.exe");
-
-die "File $confFile does not exist. Please provide the full path to the bbackupd configuration file.\n" if !(-f $confFile);
-die "Can't read $confFile. Permission denied. Please chmod the file so I can read it.\n" if !(-r $confFile);
-die "File $exeFile does not exist. Please provide the full path to the bbackupd.exe file.\n" if !(-f $exeFile);
-die "File $exeFile is not executable. Please provide the full path to the correct bbackupd.exe file.\n" if !(-x $exeFile);
-
-# print "Config: $confFile\n";
-
-my $dataDir;
-my $cmdSocket;
-my $pidFile;
-
-open (CONFIG, "<$confFile") or die "Can't open $confFile: $!\n";
-
-# Read the confgiguration file, and pull the DataDirectory, CommandSocket, and PidFile parameters.
-while (<CONFIG>)
-{
-
- if (/^\s*DataDirectory\s*=\s*([^\n\s]+)\s*\n/)
- {
- $dataDir = $1;
- next;
- }
-
- if (/^\s*CommandSocket\s*=\s*([^\n\s]+)\s*\n/)
- {
- $cmdSocket = $1;
- next;
- }
- if (/^\s*PidFile\s*=\s*([^\n\s]+)\s*\n/)
- {
- $pidFile = $1;
- next;
- }
-}
-
-# check that we got all the parameters from the file. If not, die.
-if ((!defined($dataDir)) || (!defined($cmdSocket)) || (!defined($pidFile)))
-{
- die "Could not read config parameters from $confFile. Values retrieved:\n\tDataDirectory = $dataDir\n\tCommandSocket = $cmdSocket\n\tPidFile = $pidFile\n";
-}
-
-
-print "Parameters retrieved from $confFile. Values:\n\tDataDirectory = $dataDir\n\tCommandSocket = $cmdSocket\n\tPidFile = $pidFile\n";
-print "chmod...";
-# change the mode of the files/dirs retrieved.
-chmod(0777, $dataDir) or die "Can't chmod $dataDir: $!\n";
-chmod(0666, "$dataDir/*") or die "Can't chmod $dataDir/*: $!\n";
-chmod(0666, $pidFile) or die "Can't chmod $pidFile: $!\n";
-chmod(0755, $cmdSocket) or die "Can't chmod $cmdSocket: $!\n";
-print " Done.\n";
-
-# Now install the service using cygrunsrv.
-# Details:
-# -I <svc_name> Install a service. svc_name is the name under which the
-# service will appear in the Windows Service Manager
-# -p <path_to_exe> Path to the executable.
-# -a <options> Command line options to the executable.
-# -f <description> Description of the service.
-# -o Attempt clean exit of service during system shutdown
-
-print "Installing boxbackup service...";
-my $sysCmd = "cygrunsrv.exe -I boxbackup -p " . $exeFile;
-$sysCmd .= " -a \"" . $confFile . " SINGLEPROCESS\"";
-$sysCmd .= " -o -f \"Online Backup System by Ben Summers\"";
-print "$sysCmd\n";
-my $output = qx($sysCmd);
-die "cygrunsrv failed to install service. Error Message: $output\n" if($output ne "");
-print " Done.\n";
-
-
-# Start the service
-# Details:
-# -S <svc_name> Start a service. svc_name is the name of the (installed)
-# service to start.
-
-print "Starting boxbackup service...";
-$sysCmd = "cygrunsrv.exe -S boxbackup";
-print "$sysCmd\n";
-$output = qx($sysCmd);
-die "cygrunsrv failed to start service. Error Message: $output\n" if($output ne "");
-print " Done.\n";
-
-print "\n\nService Installation complete. To test, reboot your machine, and make sure that\n";
-print "the boxbackup service is running. A good way to make sure, is to check that the account number\n";
-print "from this machine is connecting to the bbstored server. Check the bbstored logs for more info.\n\n";
-
-
diff --git a/distribution/boxbackup/contrib/cygwin/remove-cygwin-service.sh b/distribution/boxbackup/contrib/cygwin/remove-cygwin-service.sh
deleted file mode 100755
index e766333d..00000000
--- a/distribution/boxbackup/contrib/cygwin/remove-cygwin-service.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/bash
-
-# Contributed to the boxbackup project by Per Reedtz Thomsen. pthomsen@reedtz.com
-
-# This script removes the 'boxbackup' service from the Windows service manager
-# using the cygrunsrv utility.
-
-# Date Who Comments
-# 20041005 pthomsen@reedtz.com Created
-
-cygrunsrv -R boxbackup
-
-echo "Service \"boxbackup\" removed."
-
diff --git a/distribution/boxbackup/contrib/debian/README.txt b/distribution/boxbackup/contrib/debian/README.txt
deleted file mode 100644
index ebe5fdf7..00000000
--- a/distribution/boxbackup/contrib/debian/README.txt
+++ /dev/null
@@ -1,9 +0,0 @@
-These start scripts are for Debian GNU/Linux. If installed manually they should
-be placed in /etc/init.d. To create the symbolic links for the appropriate run
-levels execute the following commands:
-
-update-rc.d bbackupd defaults 90
-update-rc.d bbstored defaults 80
-
-James Stark
-<jstark@ieee.org>
diff --git a/distribution/boxbackup/contrib/debian/bbackupd b/distribution/boxbackup/contrib/debian/bbackupd
deleted file mode 100644
index e6d5326c..00000000
--- a/distribution/boxbackup/contrib/debian/bbackupd
+++ /dev/null
@@ -1,38 +0,0 @@
-#! /bin/sh
-
-# Start and stop the Box Backup client daemon.
-
-test -x /usr/local/bin/bbackupd || exit 0
-test -f /etc/box/bbackupd.conf || exit 0
-
-case $1 in
- start)
- echo -n "Starting Box Backup Client daemon: bbackupd"
- start-stop-daemon --start --quiet --exec /usr/local/bin/bbackupd > /dev/null
- echo "."
- ;;
-
- stop)
- echo -n "Stopping Box Backup Client daemon: bbackupd"
- start-stop-daemon --stop --quiet --pidfile /var/run/bbackupd.pid --exec /usr/local/bin/bbackupd
- echo "."
- ;;
-
- reload|force-reload)
- echo -n "Reloading the Box Backup Client daemon's configuration"
- start-stop-daemon --stop --signal 1 --quiet --oknodo --pidfile /var/run/bbackupd.pid --exec /usr/local/bin/bbackupd
- echo "."
- ;;
-
- restart)
- echo -n "Restarting the Box Backup Client daemon: bbackupd"
- start-stop-daemon --stop --quiet --pidfile /var/run/bbackupd.pid --exec /usr/local/bin/bbackupd
- start-stop-daemon --start --quiet --exec /usr/local/bin/bbackupd > dev/null
- echo "."
- ;;
- *)
- echo "Usage: /etc/init.d/bbackupd {start|stop|reload|force-reload|restart}"
- exit 1
-esac
-
-exit 0
diff --git a/distribution/boxbackup/contrib/debian/bbstored b/distribution/boxbackup/contrib/debian/bbstored
deleted file mode 100644
index 7a512161..00000000
--- a/distribution/boxbackup/contrib/debian/bbstored
+++ /dev/null
@@ -1,38 +0,0 @@
-#! /bin/sh
-
-# Start and stop the Box Backup Server.
-
-test -x /usr/local/bin/bbstored || exit 0
-test -f /etc/box/bbstored.conf || exit 0
-
-case $1 in
- start)
- echo -n "Starting the Box Backup Server daemon: bbstored"
- start-stop-daemon --start --quiet --exec /usr/local/bin/bbstored > /dev/null
- echo "."
- ;;
-
- stop)
- echo -n "Stopping the Box Backup Server daemon: bbstored"
- start-stop-daemon --stop --quiet --pidfile /var/run/bbstored.pid --exec /usr/local/bin/bbstored
- echo "."
- ;;
-
- reload|force-reload)
- echo -n "Reloading the Box Backup Server's configuration"
- start-stop-daemon --stop --signal 1 --quiet --oknodo --pidfile /var/run/bbstored.pid --exec /usr/local/bin/bbstored
- echo "."
- ;;
-
- restart)
- echo -n "Restarting the Box Backup Server daemon: bbstored"
- start-stop-daemon --stop --quiet --pidfile /var/run/bbstored.pid --exec /usr/local/bin/bbstored
- start-stop-daemon --start --quiet --exec /usr/local/bin/bbstored > /dev/null
- echo "."
- ;;
-
- *)
- echo "Usage /etc/init.d/bbstored {start|stop|reload|force-reload|restart}"
-esac
-
-exit 0
diff --git a/distribution/boxbackup/contrib/redhat/README.txt b/distribution/boxbackup/contrib/redhat/README.txt
deleted file mode 100644
index cfc8d968..00000000
--- a/distribution/boxbackup/contrib/redhat/README.txt
+++ /dev/null
@@ -1,7 +0,0 @@
-These start scripts are for Fedora Core or RedHat Enterprise Linux. If
-installed manually they should be placed in /etc/rc.d/init.d.
-
-They may also work for Mandrake.
-
-Martin Ebourne
-martin@zepler.org
diff --git a/distribution/boxbackup/contrib/redhat/bbackupd b/distribution/boxbackup/contrib/redhat/bbackupd
deleted file mode 100644
index 63c61ff7..00000000
--- a/distribution/boxbackup/contrib/redhat/bbackupd
+++ /dev/null
@@ -1,83 +0,0 @@
-#! /bin/bash
-#
-# bbackupd Start/Stop the box backup daemon.
-#
-# chkconfig: 345 93 07
-# description: bbackup is the client side deamon for Box Backup, a completely \
-# automatic on-line backup system
-# processname: bbackupd
-# config: /etc/box
-# pidfile: /var/run/bbackupd.pid
-
-# Source function library.
-. /etc/init.d/functions
-
-RETVAL=0
-
-# See how we were called.
-
-prog="bbackupd"
-
-# Check that configuration exists.
-[ -f /etc/box/$prog.conf ] || exit 0
-
-start() {
- echo -n $"Starting $prog: "
- daemon $prog
- RETVAL=$?
- echo
- [ $RETVAL -eq 0 ] && touch /var/lock/subsys/$prog
- return $RETVAL
-}
-
-stop() {
- echo -n $"Stopping $prog: "
- killproc $prog
- RETVAL=$?
- echo
- [ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/$prog
- return $RETVAL
-}
-
-rhstatus() {
- status $prog
-}
-
-restart() {
- stop
- start
-}
-
-reload() {
- echo -n $"Reloading $prog daemon configuration: "
- killproc $prog -HUP
- retval=$?
- echo
- return $RETVAL
-}
-
-case "$1" in
- start)
- start
- ;;
- stop)
- stop
- ;;
- restart)
- restart
- ;;
- reload)
- reload
- ;;
- status)
- rhstatus
- ;;
- condrestart)
- [ -f /var/lock/subsys/$prog ] && restart || :
- ;;
- *)
- echo $"Usage: $0 {start|stop|status|reload|restart|condrestart}"
- exit 1
-esac
-
-exit $?
diff --git a/distribution/boxbackup/contrib/redhat/bbstored b/distribution/boxbackup/contrib/redhat/bbstored
deleted file mode 100644
index eadca1d1..00000000
--- a/distribution/boxbackup/contrib/redhat/bbstored
+++ /dev/null
@@ -1,83 +0,0 @@
-#! /bin/bash
-#
-# bbstored Start/Stop the box backup daemon.
-#
-# chkconfig: 345 93 07
-# description: bbstore is the server side deamon for Box Backup, a completely \
-# automatic on-line backup system
-# processname: bbstored
-# config: /etc/box
-# pidfile: /var/run/bbstored.pid
-
-# Source function library.
-. /etc/init.d/functions
-
-RETVAL=0
-
-# See how we were called.
-
-prog="bbstored"
-
-# Check that configuration exists.
-[ -f /etc/box/$prog.conf ] || exit 0
-
-start() {
- echo -n $"Starting $prog: "
- daemon $prog
- RETVAL=$?
- echo
- [ $RETVAL -eq 0 ] && touch /var/lock/subsys/$prog
- return $RETVAL
-}
-
-stop() {
- echo -n $"Stopping $prog: "
- killproc $prog
- RETVAL=$?
- echo
- [ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/$prog
- return $RETVAL
-}
-
-rhstatus() {
- status $prog
-}
-
-restart() {
- stop
- start
-}
-
-reload() {
- echo -n $"Reloading $prog daemon configuration: "
- killproc $prog -HUP
- retval=$?
- echo
- return $RETVAL
-}
-
-case "$1" in
- start)
- start
- ;;
- stop)
- stop
- ;;
- restart)
- restart
- ;;
- reload)
- reload
- ;;
- status)
- rhstatus
- ;;
- condrestart)
- [ -f /var/lock/subsys/$prog ] && restart || :
- ;;
- *)
- echo $"Usage: $0 {start|stop|status|reload|restart|condrestart}"
- exit 1
-esac
-
-exit $?
diff --git a/distribution/boxbackup/contrib/rpm/README.txt b/distribution/boxbackup/contrib/rpm/README.txt
deleted file mode 100644
index 290a5252..00000000
--- a/distribution/boxbackup/contrib/rpm/README.txt
+++ /dev/null
@@ -1,16 +0,0 @@
-BUILDING AN RPM
-
-The easy way is to:
-
-rpmbuild -ta <tarfile>
-
-where <tarfile> is the archive you downloaded of Box Backup.
-
-This RPM should work on RedHat Enterprise, Fedora Core, Mandrake, SUSE, and
-any similar distributions. It has been developed and tested on Fedora Core.
-
-Changes for SUSE Linux were provided by Chris Smith
-(chris.smith@nothingbutnet.co.nz).
-
-Martin Ebourne
-martin@zepler.org
diff --git a/distribution/boxbackup/contrib/rpm/boxbackup.spec b/distribution/boxbackup/contrib/rpm/boxbackup.spec
deleted file mode 100644
index 111a00ff..00000000
--- a/distribution/boxbackup/contrib/rpm/boxbackup.spec
+++ /dev/null
@@ -1,240 +0,0 @@
-%define bb_user_id 171
-%define ident %{name}-%{version}
-
-# In official distribution tarballs, distribution files are copied to
-# the base directory (where configure is), so distribution_dir should be empty.
-# This is the default, overridden by the following block in non-distribution
-# builds.
-%define distribution_dir ''
-
-# BOX_PRIVATE_BEGIN
-# In unofficial tarballs, made from svn, distribution files are still in
-# distribution/boxbackup, so the following line overrides the default above:
-# (this section will be removed automatically from distribution tarballs
-# by infrastructure/makedistribution.pl)
-%define distribution_dir distribution/boxbackup/
-# BOX_PRIVATE_END
-
-# Detect distribution. So far we only special-case SUSE. If you need to make
-# any distro specific changes to get the package building on your system
-# please email them to boxbackup-dev@fluffy.co.uk
-#%define is_fc %(test -e %{_sysconfdir}/fedora-release && echo 1 || echo 0)
-#%define is_mdk %(test -e %{_sysconfdir}/mandrake-release && echo 1 || echo 0)
-#%define is_rh %(test -e %{_sysconfdir}/redhat-release && echo 1 || echo 0)
-%define is_suse %(test -e %{_sysconfdir}/SuSE-release && echo 1 || echo 0)
-
-%if %{is_suse}
-%define init_dir %{_sysconfdir}/init.d
-%define dist suse
-%define rc_start rc
-%else
-%define init_dir %{_sysconfdir}/rc.d/init.d
-%define dist redhat
-%define rc_start "service "
-%endif
-
-Summary: An automatic on-line backup system for UNIX.
-Name: boxbackup
-Version: ###DISTRIBUTION-VERSION-NUMBER###
-Release: 1
-License: BSD
-Group: Applications/Archiving
-Packager: Martin Ebourne <boxbackup-dev@fluffy.co.uk>
-URL: http://www.fluffy.co.uk/boxbackup/
-Source0: %{ident}.tgz
-Requires: openssl >= 0.9.7a
-BuildRoot: %{_tmppath}/%{ident}-%{release}-root
-BuildRequires: openssl >= 0.9.7a, openssl-devel
-
-%description
-Box Backup is a completely automatic on-line backup system. Backed up files
-are stored encrypted on a filesystem on a remote server, which does not need
-to be trusted. The backup server runs as a daemon on the client copying only
-the changes within files, and old versions and deleted files are retained. It
-is designed to be easy and cheap to run a server and (optional) RAID is
-implemented in userland for ease of use.
-
-%package client
-Summary: An automatic on-line backup system for UNIX.
-Group: Applications/Archiving
-
-%description client
-Box Backup is a completely automatic on-line backup system. Backed up files
-are stored encrypted on a filesystem on a remote server, which does not need
-to be trusted. The backup server runs as a daemon on the client copying only
-the changes within files, and old versions and deleted files are retained. It
-is designed to be easy and cheap to run a server and (optional) RAID is
-implemented in userland for ease of use.
-
-This package contains the client.
-
-%package server
-Summary: An automatic on-line backup system for UNIX.
-Group: System Environment/Daemons
-
-%description server
-Box Backup is a completely automatic on-line backup system. Backed up files
-are stored encrypted on a filesystem on a remote server, which does not need
-to be trusted. The backup server runs as a daemon on the client copying only
-the changes within files, and old versions and deleted files are retained. It
-is designed to be easy and cheap to run a server and (optional) RAID is
-implemented in userland for ease of use.
-
-This package contains the server.
-
-%prep
-%setup -q
-
-%build
-echo -e '%{version}\n%{name}' > VERSION.txt
-test -e configure || ./bootstrap
-%configure
-
-make
-
-%install
-rm -rf $RPM_BUILD_ROOT
-
-mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{ident}
-mkdir -p $RPM_BUILD_ROOT%{_bindir}
-mkdir -p $RPM_BUILD_ROOT%{_sbindir}
-mkdir -p $RPM_BUILD_ROOT%{init_dir}
-mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/box/bbackupd
-mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/box/bbstored
-mkdir -p $RPM_BUILD_ROOT%{_var}/lib/box
-
-install -m 644 BUGS.txt \
- $RPM_BUILD_ROOT%{_docdir}/%{ident}
-install -m 644 VERSION.txt \
- $RPM_BUILD_ROOT%{_docdir}/%{ident}
-install -m 644 ExceptionCodes.txt \
- $RPM_BUILD_ROOT%{_docdir}/%{ident}
-install -m 644 LICENSE.txt \
- $RPM_BUILD_ROOT%{_docdir}/%{ident}
-
-install -m 644 %{distribution_dir}CONTACT.txt \
- $RPM_BUILD_ROOT%{_docdir}/%{ident}
-install -m 644 %{distribution_dir}DOCUMENTATION.txt \
- $RPM_BUILD_ROOT%{_docdir}/%{ident}
-install -m 644 %{distribution_dir}LINUX.txt \
- $RPM_BUILD_ROOT%{_docdir}/%{ident}
-install -m 644 %{distribution_dir}THANKS.txt \
- $RPM_BUILD_ROOT%{_docdir}/%{ident}
-
-# Client
-touch $RPM_BUILD_ROOT%{_sysconfdir}/box/bbackupd.conf
-install -m 755 %{distribution_dir}contrib/%{dist}/bbackupd \
- $RPM_BUILD_ROOT%{init_dir}
-%if %{is_suse}
-ln -s ../../%{init_dir}/bbackupd $RPM_BUILD_ROOT%{_sbindir}/rcbbackupd
-%endif
-%define client_dir parcels/%{ident}-backup-client-linux-gnu
-install %{client_dir}/bbackupd $RPM_BUILD_ROOT%{_sbindir}
-install %{client_dir}/bbackupquery $RPM_BUILD_ROOT%{_sbindir}
-install %{client_dir}/bbackupctl $RPM_BUILD_ROOT%{_sbindir}
-install %{client_dir}/bbackupd-config $RPM_BUILD_ROOT%{_sbindir}
-
-# Server
-touch $RPM_BUILD_ROOT%{_sysconfdir}/box/bbstored.conf
-touch $RPM_BUILD_ROOT%{_sysconfdir}/box/raidfile.conf
-install -m 755 %{distribution_dir}contrib/%{dist}/bbstored \
- $RPM_BUILD_ROOT%{init_dir}
-%if %{is_suse}
-ln -s ../../%{init_dir}/bbstored $RPM_BUILD_ROOT%{_sbindir}/rcbbstored
-%endif
-%define server_dir parcels/%{ident}-backup-server-linux-gnu
-install %{server_dir}/bbstored $RPM_BUILD_ROOT%{_sbindir}
-install %{server_dir}/bbstoreaccounts $RPM_BUILD_ROOT%{_sbindir}
-install %{server_dir}/bbstored-certs $RPM_BUILD_ROOT%{_bindir}
-install %{server_dir}/bbstored-config $RPM_BUILD_ROOT%{_sbindir}
-install %{server_dir}/raidfile-config $RPM_BUILD_ROOT%{_sbindir}
-
-%pre server
-%{_sbindir}/useradd -c "Box Backup" -u %{bb_user_id} \
- -s /sbin/nologin -r -d / box 2> /dev/null || :
-
-%post client
-/sbin/chkconfig --add bbackupd
-if [ ! -f %{_sysconfdir}/box/bbackupd.conf ]; then
- echo "You should run the following to configure the client:"
- echo "bbackupd-config %{_sysconfdir}/box lazy <account-number> <server-host>" \
- "%{_var}/lib/box <backup-directories>"
- echo "Then follow the instructions. Use this to start the client:"
- echo "%{rc_start}bbackupd start"
-fi
-
-%post server
-/sbin/chkconfig --add bbstored
-if [ ! -f %{_sysconfdir}/box/bbstored.conf ]; then
- echo "You should run the following to configure the server:"
- echo "raidfile-config %{_sysconfdir}/box 2048 <store-directory> [<raid-directories>]"
- echo "bbstored-config %{_sysconfdir}/box" `hostname` box
- echo "Then follow the instructions. Use this to start the server:"
- echo "%{rc_start}bbstored start"
-fi
-
-%preun client
-if [ $1 = 0 ]; then
- %{init_dir}/bbackupd stop > /dev/null 2>&1
- /sbin/chkconfig --del bbackupd
-fi
-
-%preun server
-if [ $1 = 0 ]; then
- %{init_dir}/bbstored stop > /dev/null 2>&1
- /sbin/chkconfig --del bbstored
-fi
-
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%files client
-%defattr(-,root,root,-)
-%dir %attr(700,root,root) %{_sysconfdir}/box/bbackupd
-%dir %attr(755,root,root) %{_var}/lib/box
-%doc %{_docdir}/%{ident}/*.txt
-%config %{init_dir}/bbackupd
-%if %{is_suse}
-%{_sbindir}/rcbbackupd
-%endif
-%config %ghost %{_sysconfdir}/box/bbackupd.conf
-%{_sbindir}/bbackupd
-%{_sbindir}/bbackupquery
-%{_sbindir}/bbackupctl
-%{_sbindir}/bbackupd-config
-
-%files server
-%defattr(-,root,root,-)
-%dir %attr(700,box,root) %{_sysconfdir}/box/bbstored
-%config %{init_dir}/bbstored
-%if %{is_suse}
-%{_sbindir}/rcbbstored
-%endif
-%config %ghost %{_sysconfdir}/box/bbstored.conf
-%config %ghost %{_sysconfdir}/box/raidfile.conf
-%{_sbindir}/bbstored
-%{_sbindir}/bbstoreaccounts
-%{_bindir}/bbstored-certs
-%{_sbindir}/bbstored-config
-%{_sbindir}/raidfile-config
-
-%changelog
-* Sat Jan 13 2006 Chris Wilson <chris+box@qwirx.com>
-- Support building from an unofficial tarball (from svn) by changing
- %{distribution_dir} at the top.
-- Write our RPM version number into VERSION.txt and hence compile it in
-
-* Wed Dec 28 2005 Martin Ebourne <martin@zepler.org>
-- Box now uses autoconf so use configure macro
-
-* Fri Oct 1 2004 Martin Ebourne <martin@zepler.org> - 0.08-3
-- Moved most of the exes to /usr/sbin
-- SUSE updates from Chris Smith
-
-* Fri Sep 24 2004 Martin Ebourne <martin@zepler.org> - 0.08-2
-- Added support for other distros
-- Changes for SUSE provided by Chris Smith <chris.smith@nothingbutnet.co.nz>
-
-* Mon Sep 16 2004 Martin Ebourne <martin@zepler.org> - 0.07-1
-- Initial build
diff --git a/distribution/boxbackup/contrib/suse/README.txt b/distribution/boxbackup/contrib/suse/README.txt
deleted file mode 100644
index 0f260b7a..00000000
--- a/distribution/boxbackup/contrib/suse/README.txt
+++ /dev/null
@@ -1,5 +0,0 @@
-These start scripts are for SUSE Linux. If installed manually they should be
-placed in /etc/init.d.
-
-Copyright (c)2004, Nothing But Net Limited
-<chris.smith@nothingbutnet.co.nz>
diff --git a/distribution/boxbackup/contrib/suse/bbackupd b/distribution/boxbackup/contrib/suse/bbackupd
deleted file mode 100644
index 4dd94154..00000000
--- a/distribution/boxbackup/contrib/suse/bbackupd
+++ /dev/null
@@ -1,101 +0,0 @@
-#!/bin/sh
-#
-# Copyright (c)2004, Nothing But Net Limited
-# <chris.smith@nothingbutnet.co.nz>
-#
-######################################################################
-# RELEASED AND PROVIDED TO YOU UNDER THE SAME LICENCE AS THE BOXBACKUP
-# SUITE OF PROGRAMS. LICENCE MAY BE VIEWED HERE:
-#
-# http://www.fluffy.co.uk/boxbackup/license.html
-######################################################################
-#
-# /etc/init.d/bbackupd
-# and its symbolic link
-# /(usr/)sbin/rcbbackupd
-#
-### BEGIN INIT INFO
-# Provides: bbackupd
-# Required-Start: $named $network $local_fs $syslog
-# X-UnitedLinux-Should-Start: $time ypbind sendmail
-# Required-Stop: $named $network $localfs $syslog
-# X-UnitedLinux-Should-Stop: $time ypbind sendmail
-# Default-Start: 3 5
-# Default-Stop: 0 1 2 6
-# Short-Description: BoxBackup client side daemon
-# Description: Client daemon for the BoxBackup software
-# that allows you to communicate with a bbstored server.
-### END INIT INFO
-
-# Check for missing binaries (stale symlinks should not happen)
-BBACKUPD_BIN=/usr/sbin/bbackupd
-if [ ! -x $BBACKUPD_BIN ] ; then
- echo "$BBACKUPD_BIN not installed"
- exit 5
-fi
-
-. /etc/rc.status
-
-# Reset status of this service
-rc_reset
-
-case "$1" in
- start)
- echo -n "Starting bbackupd "
- startproc $BBACKUPD_BIN
- rc_status -v
- ;;
-
- stop)
- echo -n "Shutting down bbackupd "
- killproc -TERM $BBACKUPD_BIN
- rc_status -v
- ;;
-
- try-restart|condrestart)
- if test "$1" = "condrestart"; then
- echo "${attn} Use try-restart ${done}(LSB)${attn} rather than condrestart ${warn}(RH)${norm}"
- fi
- $0 status
- if test $? = 0; then
- $0 restart
- else
- rc_reset # Not running is not a failure.
- fi
- rc_status
- ;;
-
- restart)
- $0 stop
- $0 start
- rc_status
- ;;
-
- force-reload)
- echo -n "Reload service bbackupd "
- killproc -HUP $BBACKUPD_BIN
- rc_status -v
- ;;
-
- reload)
- echo -n "Reload service bbackupd "
- killproc -HUP $BBACKUPD_BIN
- rc_status -v
- ;;
-
- status)
- echo -n "Checking for service bbackupd "
- checkproc $BBACKUPD_BIN
- rc_status -v
- ;;
-
- probe)
- test /etc/box/bbackupd.conf -nt /var/run/bbackupd.pid && echo reload
- ;;
-
- *)
- echo "Usage: $0 {start|stop|status|try-restart|restart|force-reload|reload|probe}"
- exit 1
-
-esac
-rc_exit
diff --git a/distribution/boxbackup/contrib/suse/bbstored b/distribution/boxbackup/contrib/suse/bbstored
deleted file mode 100644
index 1824dda7..00000000
--- a/distribution/boxbackup/contrib/suse/bbstored
+++ /dev/null
@@ -1,103 +0,0 @@
-#!/bin/sh
-#
-# Copyright (c)2004, Nothing But Net Limited
-# <chris.smith@nothingbutnet.co.nz>
-#
-######################################################################
-# RELEASED AND PROVIDED TO YOU UNDER THE SAME LICENCE AS THE BOXBACKUP
-# SUITE OF PROGRAMS. LICENCE MAY BE VIEWED HERE:
-#
-# http://www.fluffy.co.uk/boxbackup/license.html
-######################################################################
-#
-# /etc/init.d/bbackupd
-# and its symbolic link
-# /(usr/)sbin/rcbbackupd
-#
-### BEGIN INIT INFO
-# Provides: bbackupd
-# Required-Start: $named $network $local_fs $syslog
-# X-UnitedLinux-Should-Start: $time ypbind sendmail
-# Required-Stop: $named $network $localfs $syslog
-# X-UnitedLinux-Should-Stop: $time ypbind sendmail
-# Default-Start: 3 5
-# Default-Stop: 0 1 2 6
-# Short-Description: BoxBackup server side daemon
-# Description: Client daemon for the BoxBackup software
-# that allows you to communicate with a bbstored server.
-### END INIT INFO
-#
-
-# Check for missing binaries (stale symlinks should not happen)
-BBACKUPD_BIN=/usr/sbin/bbstored
-if [ ! -x $BBACKUPD_BIN ] ; then
- echo "$BBACKUPD_BIN not installed"
- exit 5
-fi
-
-. /etc/rc.status
-
-# Reset status of this service
-rc_reset
-
-case "$1" in
- start)
- echo -n "Starting bbstored "
- startproc $BBACKUPD_BIN
- rc_status -v
- ;;
-
- stop)
- echo -n "Shutting down bstored "
- killproc -TERM $BBACKUPD_BIN
- rc_status -v
- ;;
-
- try-restart|condrestart)
- if test "$1" = "condrestart"; then
- echo "${attn} Use try-restart ${done}(LSB)${attn} rather than condrestart ${warn}(RH)${norm}"
- fi
- $0 status
- if test $? = 0; then
- $0 restart
- else
- rc_reset # Not running is not a failure.
- fi
- rc_status
- ;;
-
- restart)
- $0 stop
- $0 start
- rc_status
- ;;
-
- force-reload)
- echo -n "Reload service bbstored "
- killproc -HUP $BBACKUPD_BIN
- rc_status -v
- ;;
-
- reload)
- echo -n "Reload service bbstored "
- killproc -HUP $BBACKUPD_BIN
- rc_status -v
- ;;
-
- status)
- echo -n "Checking for service bbstored "
- checkproc $BBACKUPD_BIN
- rc_status -v
- ;;
-
- probe)
- test /etc/box/bbstored.conf -nt /var/run/bbstored.pid && echo reload
- ;;
-
- *)
- echo "Usage: $0 {start|stop|status|try-restart|restart|force-reload|reload|probe}"
- exit 1
- ;;
-
-esac
-rc_exit