summaryrefslogtreecommitdiff
path: root/documentation/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'documentation/Makefile')
-rw-r--r--documentation/Makefile27
1 files changed, 21 insertions, 6 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 4f945575..7929f613 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -8,6 +8,14 @@ NOCHUNKBOOKXSL=bb-nochunk-book.xsl
MANXSL=bb-man.xsl
HTMLPREFIX=box-html
VPATH= adminguide
+# If your OS declares a system make variable, add a .elif statement here
+# with the path to the locally-installed DocBook stylesheet
+.if .FreeBSD
+# Requires textproc/docbook-xsl port installed
+DOCBOOK=file:///usr/local/share/xsl/docbook/manpages/docbook.xsl
+.else
+DOCBOOK=http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
+.endif
.SUFFIXES: .html .xml .1 .5 .8
all: docs
@@ -31,7 +39,10 @@ $(HTMLPREFIX)/instguide/index.html: instguide.xml $(BOOKXSL)
ExceptionCodes.xml: ../ExceptionCodes.txt
perl ./generate_except_xml.pl
-manpages: man-dirs man-nroff man-html
+manpages: $(MANXSL) man-dirs man-nroff man-html
+
+$(MANXSL): $(MANXSL).tmpl
+ @sed -e 's,%%DOCBOOK%%,$(DOCBOOK),' $(MANXSL).tmpl > $(MANXSL)
man-dirs: man-pages/.there $(HTMLPREFIX)/man-html/.there
@@ -41,17 +52,21 @@ $(HTMLPREFIX)/man-html/.there:
man-pages/.there:
if [ ! -d man-pages ]; then mkdir man-pages; touch man-pages/.there; fi
-man-nroff: bbackupquery.8 bbackupctl.8 bbstoreaccounts.8 bbstored-config.8 \
- raidfile-config.8 bbstored-certs.8
+man-nroff: bbackupd.8 bbackupd-config.8 bbackupctl.8 bbackupquery.8 \
+ bbstored.8 bbstored-config.8 bbstoreaccounts.8 bbstored-certs.8 \
+ raidfile-config.8 \
+ bbackupd.conf.5 bbstored.conf.5 raidfile.conf.5
-man-html: bbackupquery.html bbackupctl.html bbstoreaccounts.html \
- bbstored-config.html raidfile-config.html bbstored-certs.html
+man-html: bbackupd.html bbackupd-config.html bbackupctl.html bbackupquery.html \
+ bbstored.html bbstored-config.html bbstoreaccounts.html bbstored-certs.html \
+ raidfile-config.html \
+ bbackupd.conf.html bbstored.conf.html raidfile.conf.html
.xml.html:
$(DBPROC) -o $@ $(NOCHUNKBOOKXSL) $<
cp $@ $(HTMLPREFIX)/man-html/.
-.xml.8:
+.xml.8 .xml.5:
$(DBPROC) -o $@ $(MANXSL) $<
cp $@ man-pages/
rm -f man-pages/$@.gz