summaryrefslogtreecommitdiff
path: root/documentation/boxbackup/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'documentation/boxbackup/Makefile')
-rw-r--r--documentation/boxbackup/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/documentation/boxbackup/Makefile b/documentation/boxbackup/Makefile
index 36016d73..5ce67c54 100644
--- a/documentation/boxbackup/Makefile
+++ b/documentation/boxbackup/Makefile
@@ -4,11 +4,11 @@
DBPROC=/usr/bin/xsltproc
BOOKXSL=bb-book.xsl
-MANXSL=bb-man.xsl
+MANXSL= /usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl
VPATH= adminguide
.SUFFIXES: .html .xml
-all: adminguide instguide
+all: adminguide instguide manpages
adminguide: adminguide/index.html
@@ -24,6 +24,14 @@ instguide/index.html: instguide.xml $(BOOKXSL)
ExceptionCodes.xml: ../../ExceptionCodes.txt
perl ./generate_except_xml.pl
+manpages: bbackupquery.html bbackupquery.1
+
+bbackupquery.html: bbackupquery.xml
+ $(DBPROC) -o man-html/bbackupquery.html $(BOOKXSL) bbackupquery.xml
+
+bbackupquery.1: bbackupquery.xml
+ $(DBPROC) -o man-pages/bbackupquery.1 $(MANXSL) bbackupquery.xml
+
dockit: instguide adminguide
tar zcf documentation-kit-0.10.tar.gz html/ instguide/ adminguide/