summaryrefslogtreecommitdiff
path: root/documentation/boxbackup/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'documentation/boxbackup/Makefile')
-rw-r--r--documentation/boxbackup/Makefile37
1 files changed, 20 insertions, 17 deletions
diff --git a/documentation/boxbackup/Makefile b/documentation/boxbackup/Makefile
index 429976ee..aebe72bd 100644
--- a/documentation/boxbackup/Makefile
+++ b/documentation/boxbackup/Makefile
@@ -6,54 +6,57 @@ DBPROC=/usr/bin/xsltproc
BOOKXSL=bb-book.xsl
NOCHUNKBOOKXSL=bb-nochunk-book.xsl
MANXSL=bb-man.xsl
+HTMLPREFIX=box-html
VPATH= adminguide
.SUFFIXES: .html .xml
-all: adminguide instguide manpages
+all: adminguide instguide manpages
-adminguide: adminguide/index.html
+adminguide: $(HTMLPREFIX)/adminguide/index.html
-adminguide/index.html: adminguide.xml ExceptionCodes.xml $(BOOKXSL)
+$(HTMLPREFIX)/adminguide/index.html: adminguide.xml ExceptionCodes.xml $(BOOKXSL)
# docname=`echo $@ | sed -e 's/\/index.html//'`
- $(DBPROC) -o adminguide/ $(BOOKXSL) adminguide.xml
+ $(DBPROC) -o $(HTMLPREFIX)/adminguide/ $(BOOKXSL) adminguide.xml
-instguide: instguide/index.html
+instguide: $(HTMLPREFIX)/instguide/index.html
-instguide/index.html: instguide.xml $(BOOKXSL)
- $(DBPROC) -o instguide/ $(BOOKXSL) instguide.xml
+$(HTMLPREFIX)/instguide/index.html: instguide.xml $(BOOKXSL)
+ $(DBPROC) -o $(HTMLPREFIX)/instguide/ $(BOOKXSL) instguide.xml
ExceptionCodes.xml: ../../ExceptionCodes.txt
perl ./generate_except_xml.pl
manpages: man-dirs man-nroff man-html
-man-dirs: man-pages/.there man-html/.there
+man-dirs: man-pages/.there $(HTMLPREFIX)/man-html/.there
-man-html/.there:
- if [ ! -d man-html ]; then mkdir man-html; touch man-html/.there; fi
+$(HTMLPREFIX)/man-html/.there:
+ if [ ! -d man-html ]; then mkdir -p $(HTMLPREFIX)/man-html; touch $(HTMLPREFIX)/man-html/.there; fi
man-pages/.there:
if [ ! -d man-pages ]; then mkdir man-pages; touch man-pages/.there; fi
-man-nroff: bbackupquery.1 bbackupctl.1
+man-nroff: bbackupquery.1 bbackupctl.1 bbstoreaccounts.1
-man-html: bbackupquery.html bbackupctl.html
+man-html: bbackupquery.html bbackupctl.html bbstoreaccounts.html
%.html: %.xml
$(DBPROC) -o $@ $(NOCHUNKBOOKXSL) $<
- mv $@ man-html/.
+ mv $@ $(HTMLPREFIX)/man-html/.
%.1: %.xml
$(DBPROC) -o $@ $(MANXSL) $<
mv $@ man-pages/.
+ gzip -f -9 man-pages/$@
dockit: instguide adminguide manpages
- tar zcf documentation-kit-0.10.tar.gz html/ instguide/ adminguide/ man-html/ man-pages
+ mkdir $(HTMLPREFIX)/images
+ cp html/images/*.png $(HTMLPREFIX)/images/.
+ cp html/*.css $(HTMLPREFIX)/.
+ tar zcf documentation-kit-0.10.tar.gz $(HTMLPREFIX)/
clean:
- if [ -d ./instguide ]; then rm -rf ./instguide/; fi
- if [ -d ./adminguide ]; then rm -rf ./adminguide/; fi
- if [ -d ./man-html ]; then rm -rf ./man-html/; fi
+ if [ -d ./$(HTMLPREFIX) ]; then rm -rf $(HTMLPREFIX) ; fi
if [ -d ./man-pages ]; then rm -rf ./man-pages/; fi
if [ -f ExceptionCodes.xml ]; then rm ExceptionCodes.xml; fi
if [ -f docuemtation-kit-0.10.tar.gz ]; then rm documentation-kit-0.10.tar.gz; fi