summaryrefslogtreecommitdiff
path: root/infrastructure/cmake/windows
diff options
context:
space:
mode:
Diffstat (limited to 'infrastructure/cmake/windows')
-rw-r--r--infrastructure/cmake/windows/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/infrastructure/cmake/windows/CMakeLists.txt b/infrastructure/cmake/windows/CMakeLists.txt
index a6d93ee8..1c88472e 100644
--- a/infrastructure/cmake/windows/CMakeLists.txt
+++ b/infrastructure/cmake/windows/CMakeLists.txt
@@ -35,7 +35,7 @@ ExternalProject_Add(zlib
URL "http://zlib.net/zlib-${ZLIB_VERSION}.tar.gz"
URL_HASH ${ZLIB_HASH}
DOWNLOAD_NO_PROGRESS 1
- CMAKE_ARGS -DCMAKE_INSTALL_PREFIX=${install_dir}
+ CMAKE_ARGS -DCMAKE_INSTALL_PREFIX=${install_dir} ${SUB_CMAKE_EXTRA_ARGS}
# We need to build both versions, debug and release, because cmake requires both to be
# present to generate its multi-configuration project files for Visual Studio/MSBuild.
INSTALL_COMMAND ${CMAKE_COMMAND} --build <BINARY_DIR> --target install --config Debug
@@ -86,7 +86,7 @@ ExternalProject_Add(pcre
SVN_REPOSITORY svn://vcs.exim.org/pcre/code/trunk
SVN_REVISION -r 1677
DOWNLOAD_NO_PROGRESS 1
- CMAKE_ARGS -DCMAKE_INSTALL_PREFIX=${install_dir}
+ CMAKE_ARGS -DCMAKE_INSTALL_PREFIX=${install_dir} ${SUB_CMAKE_EXTRA_ARGS}
-DPCRE_SUPPORT_LIBREADLINE=OFF
-DPCRE_SUPPORT_LIBBZ2=OFF
# We need to build both versions, debug and release, because cmake requires both to be
@@ -122,5 +122,6 @@ ExternalProject_Add(boxbackup
-DAPPVEYOR_MODE=1
-DDEBUG=${DEBUG}
${boxbackup_cmake_args}
+ ${SUB_CMAKE_EXTRA_ARGS}
STEP_TARGETS configure build install
)