summaryrefslogtreecommitdiff
path: root/infrastructure/makebuildenv.pl.in
diff options
context:
space:
mode:
Diffstat (limited to 'infrastructure/makebuildenv.pl.in')
-rwxr-xr-xinfrastructure/makebuildenv.pl.in18
1 files changed, 10 insertions, 8 deletions
diff --git a/infrastructure/makebuildenv.pl.in b/infrastructure/makebuildenv.pl.in
index 8664f3d7..456bd265 100755
--- a/infrastructure/makebuildenv.pl.in
+++ b/infrastructure/makebuildenv.pl.in
@@ -12,7 +12,7 @@ $|=1;
# note: Mac OS X resource forks and .DS_Store files are explicity ignored
-print "Box build environment setup.\n\n";
+print "Box build environment setup.\n";
my @implicit_deps = ('lib/common');
@@ -20,6 +20,8 @@ my @implicit_deps = ('lib/common');
use lib 'infrastructure';
use BoxPlatform;
+print "Building on '$build_os'.\n\n";
+
# keep copy of command line args
my $makebuildenv_args = join(' ',@ARGV);
@@ -525,19 +527,19 @@ __E
# do not edit!
#
#
-CXX = "@CXX@"
-AR = "@AR@"
-RANLIB = "@RANLIB@"
-PERL = "@PERL@"
+CXX = @CXX@
+AR = @AR@
+RANLIB = @RANLIB@
+PERL = @PERL@
WINDRES = windres
.ifdef RELEASE
-CXXFLAGS = -DNDEBUG $release_flags -Wall -Wundef $include_paths $extra_platform_defines -DBOX_VERSION="\\"$product_version\\""
+CXXFLAGS = -DNDEBUG $release_flags @CXXFLAGS_STRICT@ $include_paths $extra_platform_defines -DBOX_VERSION="\\"$product_version\\""
OUTBASE = ../../release
OUTDIR = ../../release/$mod
DEPENDMAKEFLAGS = -D RELEASE
VARIENT = RELEASE
.else
-CXXFLAGS = -g -Wall -Wundef $include_paths $extra_platform_defines -DBOX_VERSION="\\"$product_version\\""
+CXXFLAGS = -g @CXXFLAGS_STRICT@ $include_paths $extra_platform_defines -DBOX_VERSION="\\"$product_version\\""
OUTBASE = ../../debug
OUTDIR = ../../debug/$mod
DEPENDMAKEFLAGS =
@@ -741,7 +743,7 @@ __E
additional_objects_from_make_fragment("$mod/Makefile.extra", \@objs, \@makefile_includes);
additional_objects_from_make_fragment("$mod/Makefile.extra.$build_os", \@objs, \@makefile_includes);
- my $o_file_list = join(' ',map {'$(OUTDIR)/'.$_.'.o'} @objs);
+ my $o_file_list = join(' ',map {'$(OUTDIR)/'.$_.'.o'} sort @objs);
if ($has_deps and not $bsd_make)
{