summaryrefslogtreecommitdiff
path: root/infrastructure/mingw
diff options
context:
space:
mode:
Diffstat (limited to 'infrastructure/mingw')
-rwxr-xr-xinfrastructure/mingw/compile-boxbackup-cygwin.sh12
1 files changed, 10 insertions, 2 deletions
diff --git a/infrastructure/mingw/compile-boxbackup-cygwin.sh b/infrastructure/mingw/compile-boxbackup-cygwin.sh
index 38e94735..02b05852 100755
--- a/infrastructure/mingw/compile-boxbackup-cygwin.sh
+++ b/infrastructure/mingw/compile-boxbackup-cygwin.sh
@@ -26,9 +26,17 @@ wget -c $openssl_source/$latest_openssl.tar.gz
tar xzf $latest_openssl.tar.gz --exclude $latest_openssl/Makefile
(
cd $latest_openssl
- [ -r Makefile ] || \
- ./Configure --prefix=$install_prefix mingw64 \
+ ./Configure --prefix=$install_prefix mingw64 \
--cross-compile-prefix=$compiler_prefix-
+
+ # Avoid recompilation by caching the previous Makefile for its timestamp,
+ # and reusing if it hasn't changed.
+ if diff --brief Makefile ../openssl.makefile.cache; then
+ cp -a ../openssl.makefile.cache Makefile
+ else
+ cp -a Makefile ../openssl.makefile.cache
+ fi
+
make
make install_sw
)