summaryrefslogtreecommitdiff
path: root/infrastructure
diff options
context:
space:
mode:
Diffstat (limited to 'infrastructure')
-rw-r--r--infrastructure/cmake/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index 22818a78..8af365eb 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -152,7 +152,8 @@ foreach(module_dep
set(module_path ${base_dir}/${module_dir})
string(REPLACE "/" "_" module_name ${CMAKE_MATCH_1})
string(REPLACE "/" "_" dependencies "${CMAKE_MATCH_2}")
- file(GLOB module_files ${module_path}/*.c ${module_path}/*.cpp)
+ file(GLOB module_files ${module_path}/*.c ${module_path}/*.cpp
+ ${module_path}/*.h)
set(module_files ${module_files} ${${module_name}_extra_files})
# everything except qdbm, lib/common and lib/win32 implicitly depend on