summaryrefslogtreecommitdiff
path: root/infrastructure
diff options
context:
space:
mode:
Diffstat (limited to 'infrastructure')
-rwxr-xr-xinfrastructure/makebuildenv.pl.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/infrastructure/makebuildenv.pl.in b/infrastructure/makebuildenv.pl.in
index 2130fe98..1b2f87e7 100755
--- a/infrastructure/makebuildenv.pl.in
+++ b/infrastructure/makebuildenv.pl.in
@@ -613,6 +613,12 @@ _RANLIB = \$(if \$(V),\$(RANLIB), @ echo " [RANLIB] \$@" && \$(RANLIB))
__E
}
+
+ # if there is a Makefile.pre, include it now
+ if(-e "$mod/Makefile.pre")
+ {
+ print MAKE ".include <Makefile.pre>\n\n";
+ }
# read directory
opendir DIR,$mod;
@@ -733,7 +739,7 @@ __E
$has_deps = 1;
$has_deps = 0 if $target_is_library;
- # Depenency stuff
+ # Dependency stuff
my $deps_makeinfo;
if($has_deps)
{