summaryrefslogtreecommitdiff
path: root/lib/common/BoxConfig.h
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common/BoxConfig.h')
-rw-r--r--lib/common/BoxConfig.h476
1 files changed, 0 insertions, 476 deletions
diff --git a/lib/common/BoxConfig.h b/lib/common/BoxConfig.h
deleted file mode 100644
index 71fa5e51..00000000
--- a/lib/common/BoxConfig.h
+++ /dev/null
@@ -1,476 +0,0 @@
-// distribution boxbackup-0.11rc2 (svn version: 2072)
-//
-// Copyright (c) 2003 - 2008
-// Ben Summers and contributors. All rights reserved.
-//
-// Redistribution and use in source and binary forms, with or without
-// modification, are permitted provided that the following conditions
-// are met:
-//
-// 1. Redistributions of source code must retain the above copyright
-// notice, this list of conditions and the following disclaimer.
-// 2. Redistributions in binary form must reproduce the above copyright
-// notice, this list of conditions and the following disclaimer in the
-// documentation and/or other materials provided with the distribution.
-// 3. All use of this software and associated advertising materials must
-// display the following acknowledgment:
-// This product includes software developed by Ben Summers.
-// 4. The names of the Authors may not be used to endorse or promote
-// products derived from this software without specific prior written
-// permission.
-//
-// [Where legally impermissible the Authors do not disclaim liability for
-// direct physical injury or death caused solely by defects in the software
-// unless it is modified by a third party.]
-//
-// THIS SOFTWARE IS PROVIDED BY THE AUTHORS ``AS IS'' AND ANY EXPRESS OR
-// IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-// WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-// DISCLAIMED. IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY DIRECT,
-// INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-// (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-// SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-// HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-// STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
-// ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-// POSSIBILITY OF SUCH DAMAGE.
-//
-//
-//
-/* lib/common/BoxConfig.h. Generated by configure. */
-/* lib/common/BoxConfig.h.in. Generated from configure.ac by autoheader. */
-
-/* Define to major version for BDB_VERSION */
-#define BDB_VERSION_MAJOR 4
-
-/* Define to minor version for BDB_VERSION */
-#define BDB_VERSION_MINOR 3
-
-/* Define to point version for BDB_VERSION */
-#define BDB_VERSION_POINT 29
-
-/* Name of the 64 bit endian swapping function */
-#define BSWAP64 __cpu_to_be64
-
-/* Define to 1 if the `closedir' function returns void instead of `int'. */
-/* #undef CLOSEDIR_VOID */
-
-/* Define to 1 if non-aligned int16 access will fail */
-/* #undef HAVE_ALIGNED_ONLY_INT16 */
-
-/* Define to 1 if non-aligned int32 access will fail */
-/* #undef HAVE_ALIGNED_ONLY_INT32 */
-
-/* Define to 1 if non-aligned int64 access will fail */
-/* #undef HAVE_ALIGNED_ONLY_INT64 */
-
-/* Define to 1 if you have the <asm/byteorder.h> header file. */
-#define HAVE_ASM_BYTEORDER_H 1
-
-/* Define to 1 if BSWAP64 is defined to the name of a valid 64 bit endian
- swapping function */
-#define HAVE_BSWAP64 1
-
-/* Define to 1 if you have the <db.h> header file. */
-#define HAVE_DB_H 1
-
-/* Define to 1 if you have the declaration of `dirfd', and to 0 if you don't.
- */
-#define HAVE_DECL_DIRFD 1
-
-/* Define to 1 if you have the declaration of `F_SETLK', and to 0 if you
- don't. */
-#define HAVE_DECL_F_SETLK 1
-
-/* Define to 1 if you have the declaration of `INFTIM', and to 0 if you don't.
- */
-#define HAVE_DECL_INFTIM 0
-
-/* Define to 1 if you have the declaration of `optreset', and to 0 if you
- don't. */
-#define HAVE_DECL_OPTRESET 0
-
-/* Define to 1 if you have the declaration of `O_BINARY', and to 0 if you
- don't. */
-#define HAVE_DECL_O_BINARY 0
-
-/* Define to 1 if you have the declaration of `O_EXLOCK', and to 0 if you
- don't. */
-#define HAVE_DECL_O_EXLOCK 0
-
-/* Define to 1 if you have the declaration of `SO_PEERCRED', and to 0 if you
- don't. */
-#define HAVE_DECL_SO_PEERCRED 1
-
-/* Define to 1 if you have the declaration of `XATTR_NOFOLLOW', and to 0 if
- you don't. */
-#define HAVE_DECL_XATTR_NOFOLLOW 0
-
-/* Define to 1 if #define of pragmas works */
-/* #undef HAVE_DEFINE_PRAGMA */
-
-/* Define to 1 if you have the <dirent.h> header file, and it defines `DIR'.
- */
-#define HAVE_DIRENT_H 1
-
-/* Define to 1 if `dd_fd' is member of `DIR'. */
-/* #undef HAVE_DIR_DD_FD */
-
-/* Define to 1 if `d_fd' is member of `DIR'. */
-/* #undef HAVE_DIR_D_FD */
-
-/* Define to 1 if you have the <dlfcn.h> header file. */
-#define HAVE_DLFCN_H 1
-
-/* Define to 1 if you have the <editline/readline.h> header file. */
-#define HAVE_EDITLINE_READLINE_H 1
-
-/* define if the compiler supports exceptions */
-#define HAVE_EXCEPTIONS
-
-/* Define to 1 if you have the <execinfo.h> header file. */
-#define HAVE_EXECINFO_H 1
-
-/* Define to 1 if you have the `flock' function. */
-#define HAVE_FLOCK 1
-
-/* Define to 1 if you have the `getmntent' function. */
-#define HAVE_GETMNTENT 1
-
-/* Define to 1 if you have the <getopt.h> header file. */
-#define HAVE_GETOPT_H 1
-
-/* Define to 1 if you have the `getpeereid' function. */
-/* #undef HAVE_GETPEEREID */
-
-/* Define to 1 if you have the `getpid' function. */
-#define HAVE_GETPID 1
-
-/* Define to 1 if you have the `gettimeofday' function. */
-#define HAVE_GETTIMEOFDAY 1
-
-/* Define to 1 if you have the `getxattr' function. */
-#define HAVE_GETXATTR 1
-
-/* Define to 1 if you have the <history.h> header file. */
-/* #undef HAVE_HISTORY_H */
-
-/* Define to 1 if you have the <inttypes.h> header file. */
-#define HAVE_INTTYPES_H 1
-
-/* Define to 1 if you have the `kqueue' function. */
-/* #undef HAVE_KQUEUE */
-
-/* Define to 1 if large files are supported */
-#define HAVE_LARGE_FILE_SUPPORT 1
-
-/* Define to 1 if you have the `lchown' function. */
-#define HAVE_LCHOWN 1
-
-/* Define to 1 if you have the `lgetxattr' function. */
-#define HAVE_LGETXATTR 1
-
-/* Define to 1 if you have the `crypto' library (-lcrypto). */
-#define HAVE_LIBCRYPTO 1
-
-/* Define if you have a readline compatible library */
-#define HAVE_LIBREADLINE 1
-
-/* Define to 1 if you have the `ssl' library (-lssl). */
-#define HAVE_LIBSSL 1
-
-/* Define to 1 if you have the `z' library (-lz). */
-#define HAVE_LIBZ 1
-
-/* Define to 1 if you have the `listxattr' function. */
-#define HAVE_LISTXATTR 1
-
-/* Define to 1 if you have the `llistxattr' function. */
-#define HAVE_LLISTXATTR 1
-
-/* Define to 1 if syscall lseek requires a dummy middle parameter */
-/* #undef HAVE_LSEEK_DUMMY_PARAM */
-
-/* Define to 1 if you have the `lsetxattr' function. */
-#define HAVE_LSETXATTR 1
-
-/* Define to 1 if you have the <memory.h> header file. */
-#define HAVE_MEMORY_H 1
-
-/* Define to 1 if you have the <mntent.h> header file. */
-#define HAVE_MNTENT_H 1
-
-/* Define to 1 if this platform supports mounts */
-#define HAVE_MOUNTS 1
-
-/* define if the compiler implements namespaces */
-#define HAVE_NAMESPACES
-
-/* Define to 1 if you have the <ndir.h> header file, and it defines `DIR'. */
-/* #undef HAVE_NDIR_H */
-
-/* Define to 1 if you have the <netinet/in.h> header file. */
-#define HAVE_NETINET_IN_H 1
-
-/* Define to 1 if SSL is pre-0.9.7 */
-/* #undef HAVE_OLD_SSL */
-
-/* Define to 1 if you have the <openssl/ssl.h> header file. */
-#define HAVE_OPENSSL_SSL_H 1
-
-/* Define to 1 if pcreposix.h is available */
-/* #undef HAVE_PCREPOSIX_H */
-
-/* Define to 1 if you have the <process.h> header file. */
-/* #undef HAVE_PROCESS_H */
-
-/* Define to 1 if you have the <pwd.h> header file. */
-#define HAVE_PWD_H 1
-
-/* Define to 1 (and set RANDOM_DEVICE) if a random device is available */
-#define HAVE_RANDOM_DEVICE 1
-
-/* Define to 1 if you have the <readline.h> header file. */
-/* #undef HAVE_READLINE_H */
-
-/* Define if your readline library has add_history */
-#define HAVE_READLINE_HISTORY 1
-
-/* Define to 1 if you have the <readline/history.h> header file. */
-/* #undef HAVE_READLINE_HISTORY_H */
-
-/* Define to 1 if you have the <readline/readline.h> header file. */
-/* #undef HAVE_READLINE_READLINE_H */
-
-/* Define to 1 if regex.h is available */
-#define HAVE_REGEX_H 1
-
-/* Define to 1 if regular expressions are supported */
-#define HAVE_REGEX_SUPPORT 1
-
-/* Define to 1 if you have the `setproctitle' function. */
-/* #undef HAVE_SETPROCTITLE */
-
-/* Define to 1 if you have the `setxattr' function. */
-#define HAVE_SETXATTR 1
-
-/* Define to 1 if you have the <signal.h> header file. */
-#define HAVE_SIGNAL_H 1
-
-/* Define to 1 if SSL is available */
-#define HAVE_SSL 1
-
-/* Define to 1 if you have the `statfs' function. */
-#define HAVE_STATFS 1
-
-/* Define to 1 if `stat' has the bug that it succeeds when given the
- zero-length file name argument. */
-/* #undef HAVE_STAT_EMPTY_STRING_BUG */
-
-/* Define to 1 if stdbool.h conforms to C99. */
-#define HAVE_STDBOOL_H 1
-
-/* Define to 1 if you have the <stdint.h> header file. */
-#define HAVE_STDINT_H 1
-
-/* Define to 1 if you have the <stdlib.h> header file. */
-#define HAVE_STDLIB_H 1
-
-/* Define to 1 if you have the <strings.h> header file. */
-#define HAVE_STRINGS_H 1
-
-/* Define to 1 if you have the <string.h> header file. */
-#define HAVE_STRING_H 1
-
-/* Define to 1 if `d_ino' is member of `struct dirent'. */
-#define HAVE_STRUCT_DIRENT_D_INO 1
-
-/* Define to 1 if `d_type' is member of `struct dirent'. */
-#define HAVE_STRUCT_DIRENT_D_TYPE 1
-
-/* Define to 1 if `mnt_dir' is member of `struct mntent'. */
-#define HAVE_STRUCT_MNTENT_MNT_DIR 1
-
-/* Define to 1 if `mnt_mountp' is member of `struct mnttab'. */
-/* #undef HAVE_STRUCT_MNTTAB_MNT_MOUNTP */
-
-/* Define to 1 if `sin_len' is member of `struct sockaddr_in'. */
-/* #undef HAVE_STRUCT_SOCKADDR_IN_SIN_LEN */
-
-/* Define to 1 if `f_mntonname' is member of `struct statfs'. */
-/* #undef HAVE_STRUCT_STATFS_F_MNTONNAME */
-
-/* Define to 1 if `f_mntonname' is member of `struct statvfs'. */
-/* #undef HAVE_STRUCT_STATVFS_F_MNTONNAME */
-
-/* Define to 1 if `st_flags' is member of `struct stat'. */
-/* #undef HAVE_STRUCT_STAT_ST_FLAGS */
-
-/* Define to 1 if `st_mtimespec' is member of `struct stat'. */
-/* #undef HAVE_STRUCT_STAT_ST_MTIMESPEC */
-
-/* Define to 1 if you have the `syscall' function. */
-#define HAVE_SYSCALL 1
-
-/* Define to 1 if you have the <syslog.h> header file. */
-#define HAVE_SYSLOG_H 1
-
-/* Define to 1 if you have the <sys/dir.h> header file, and it defines `DIR'.
- */
-/* #undef HAVE_SYS_DIR_H */
-
-/* Define to 1 if you have the <sys/endian.h> header file. */
-/* #undef HAVE_SYS_ENDIAN_H */
-
-/* Define to 1 if you have the <sys/mnttab.h> header file. */
-/* #undef HAVE_SYS_MNTTAB_H */
-
-/* Define to 1 if you have the <sys/mount.h> header file. */
-#define HAVE_SYS_MOUNT_H 1
-
-/* Define to 1 if you have the <sys/ndir.h> header file, and it defines `DIR'.
- */
-/* #undef HAVE_SYS_NDIR_H */
-
-/* Define to 1 if you have the <sys/param.h> header file. */
-#define HAVE_SYS_PARAM_H 1
-
-/* Define to 1 if you have the <sys/socket.h> header file. */
-#define HAVE_SYS_SOCKET_H 1
-
-/* Define to 1 if you have the <sys/stat.h> header file. */
-#define HAVE_SYS_STAT_H 1
-
-/* Define to 1 if you have the <sys/syscall.h> header file. */
-#define HAVE_SYS_SYSCALL_H 1
-
-/* Define to 1 if you have the <sys/time.h> header file. */
-#define HAVE_SYS_TIME_H 1
-
-/* Define to 1 if you have the <sys/types.h> header file. */
-#define HAVE_SYS_TYPES_H 1
-
-/* Define to 1 if you have the <sys/uio.h> header file. */
-#define HAVE_SYS_UIO_H 1
-
-/* Define to 1 if you have the <sys/wait.h> header file. */
-#define HAVE_SYS_WAIT_H 1
-
-/* Define to 1 if you have the <sys/xattr.h> header file. */
-#define HAVE_SYS_XATTR_H 1
-
-/* Define to 1 if you have the <time.h> header file. */
-#define HAVE_TIME_H 1
-
-/* Define to 1 if the system has the type `uint16_t'. */
-#define HAVE_UINT16_T 1
-
-/* Define to 1 if the system has the type `uint32_t'. */
-#define HAVE_UINT32_T 1
-
-/* Define to 1 if the system has the type `uint64_t'. */
-#define HAVE_UINT64_T 1
-
-/* Define to 1 if the system has the type `uint8_t'. */
-#define HAVE_UINT8_T 1
-
-/* Define to 1 if you have the <unistd.h> header file. */
-#define HAVE_UNISTD_H 1
-
-/* Define to 1 if the system has the type `u_int16_t'. */
-#define HAVE_U_INT16_T 1
-
-/* Define to 1 if the system has the type `u_int32_t'. */
-#define HAVE_U_INT32_T 1
-
-/* Define to 1 if the system has the type `u_int64_t'. */
-#define HAVE_U_INT64_T 1
-
-/* Define to 1 if the system has the type `u_int8_t'. */
-#define HAVE_U_INT8_T 1
-
-/* Define to 1 if struct dirent.d_type is valid */
-/* #undef HAVE_VALID_DIRENT_D_TYPE */
-
-/* Define to 1 if the system has the type `_Bool'. */
-/* #undef HAVE__BOOL */
-
-/* Define to 1 if you have the `__syscall' function. */
-/* #undef HAVE___SYSCALL */
-
-/* Define to 1 if __syscall is available but needs a definition */
-/* #undef HAVE___SYSCALL_NEED_DEFN */
-
-/* Define to 1 if `lstat' dereferences a symlink specified with a trailing
- slash. */
-#define LSTAT_FOLLOWS_SLASHED_SYMLINK 1
-
-/* Define to the address where bug reports for this package should be sent. */
-#define PACKAGE_BUGREPORT "boxbackup@fluffy.co.uk"
-
-/* Define to the full name of this package. */
-#define PACKAGE_NAME "Box Backup"
-
-/* Define to the full name and version of this package. */
-#define PACKAGE_STRING "Box Backup 0.11"
-
-/* Define to the one symbol short name of this package. */
-#define PACKAGE_TARNAME "box-backup"
-
-/* Define to the version of this package. */
-#define PACKAGE_VERSION "0.11"
-
-/* Location of the perl executable */
-#define PERL_EXECUTABLE "/usr/bin/perl"
-
-/* Define to the filename of the random device (and set HAVE_RANDOM_DEVICE) */
-#define RANDOM_DEVICE "/dev/urandom"
-
-/* Define as the return type of signal handlers (`int' or `void'). */
-#define RETSIGTYPE void
-
-/* Define to 1 if you have the ANSI C header files. */
-#define STDC_HEADERS 1
-
-/* TMP directory name */
-#define TEMP_DIRECTORY_NAME "/tmp"
-
-/* Define to 1 if you can safely include both <sys/time.h> and <time.h>. */
-#define TIME_WITH_SYS_TIME 1
-
-/* Define to 1 if your <sys/time.h> declares `struct tm'. */
-/* #undef TM_IN_SYS_TIME */
-
-/* Define to 1 if your processor stores words with the most significant byte
- first (like Motorola and SPARC, unlike Intel and VAX). */
-/* #undef WORDS_BIGENDIAN */
-
-/* Number of bits in a file offset, on hosts where this is settable. */
-#define _FILE_OFFSET_BITS 64
-
-/* Define for large files, on AIX-style hosts. */
-/* #undef _LARGE_FILES */
-
-/* Define to 1 if __USE_MALLOC is required work around STL memory leaks */
-/* #undef __USE_MALLOC */
-
-/* Define to empty if `const' does not conform to ANSI C. */
-/* #undef const */
-
-/* Define to `int' if <sys/types.h> doesn't define. */
-/* #undef gid_t */
-
-/* Define to `int' if <sys/types.h> does not define. */
-/* #undef mode_t */
-
-/* Define to `long' if <sys/types.h> does not define. */
-/* #undef off_t */
-
-/* Define to `int' if <sys/types.h> does not define. */
-/* #undef pid_t */
-
-/* Define to `unsigned' if <sys/types.h> does not define. */
-/* #undef size_t */
-
-/* Define to `int' if <sys/types.h> doesn't define. */
-/* #undef uid_t */