summaryrefslogtreecommitdiff
path: root/lib/backupstore/BackupStoreCheck.cpp
Commit message (Collapse)AuthorAge
* New upstream version 0.13~~git20190527.g039c4a1Reinhard Tartler2019-05-28
|
* Catch exceptions during destruction of BackupStoreCheck as well.Chris Wilson2015-12-24
| | | | | Like HousekeepStoreAccount, throwing an exception during the destructor will terminate the application in an "unusual way".
* Fix test failures caused by using plain stat() instead of emu_stat().Chris Wilson2014-12-26
| | | | | | | On Windows, plain stat() no longer handles slashes in filenames correctly (since upgrading MinGW? Or switching to 64-bit Windows?). We need to use POSIX fstat() for now in RaidFile, but we can still use the emu_stat, and in fact we should, to fix path translation.
* Fix test failures caused by store path ending with slash on Windows.Chris Wilson2014-12-26
|
* Replace sprintf() with snprintf(), fixes compile warnings on OpenBSD.Chris Wilson2014-12-22
| | | | | And compile errors on recent MinGW.
* Repair the refcount database while checking accounts for errors.Chris Wilson2014-10-31
| | | | | | | Normally this will be done by housekeeping anyway, so it's not that useful, but it's good to check for it in tests, especially when testing BackupStoreCheck's ability to repair bad things that happened to the store when they involve references.
* Whitespace, comment and readability fixesChris Wilson2014-10-31
|
* Directories' entries in parent directory should track current size.Chris Wilson2014-04-09
| | | | | | | | | | | | | | | | | | | | | | When entries are added to a directory by a command (BackupStoreContext), and when entries are removed from a directory (by housekeeping), update the parent directory's entry for us if our size has changed. Make BackupStoreCheck check for, report and fix errors when directory entries are directories and the size is wrong (as well as files). Conflicts: test/backupstore/testbackupstore.cpp Fix directories loaded without size being set, leading to warnings later. We can't check that the old size in the parent entry matched the old real size of the directory, unless we set the old real size in the directory. And we don't need to pass the old directory size to HousekeepStoreAccount::DeleteFile, because we can get it from the directory itself.
* Whitespace, comments and log messages cleanups.Chris Wilson2014-03-02
|
* Allow read-only account check without taking a write lock on account.Chris Wilson2014-02-27
|
* Rename BackupStoreInfo variable NumFiles to NumCurrentFiles.Chris Wilson2014-02-09
| | | | | Will hopefully prevent future confusion about the meaning of this info variable.
* Fix accounting in bbstoreaccounts check.Chris Wilson2014-02-09
| | | | | | Fix accounting for current, old and deleted files and blocks. Previously there was confusion over the meaning of NumFiles, now it's defined to mean the number of current files (neither old nor deleted), similar to BlocksInCurrentFiles.
* The user asked us to fix errors, so it's not a very important notification ↵Chris Wilson2014-02-09
| | | | that we're doing so.
* Create new refcount database atomically during account check.Chris Wilson2014-02-07
| | | | | | | | | | | Use a temporary refcount db for check instead of an in-memory vector. This avoid the memory usage problems created by using the vector on large accounts, but may require us to improve the efficiency of the refcount database itself to avoid large numbers of small I/O operations. That is very doable now that we're using a class for it. Fix some inconsistencies and mistakes in handling reference counts and info counters during account checks (more to come).
* Files are allowed to be both Old and Deleted.Chris Wilson2013-10-02
| | | | Count them as Deleted, not as Old.
* Repair damaged Box RAID objects and non-transformed .rfw files.Chris Wilson2013-09-20
|
* Repeatedly "fix" directories until all errors are cleared.Chris Wilson2013-09-19
| | | | | | | Fixes some cases where a directory might refer to an object that doesn't exist, which is removed from the directory, but an object that depends on it (a patch) isn't removed, and requires a subsequent recheck.
* Fix missing include, thanks Arnaud.Chris Wilson2013-09-02
|
* Improve debugging messages after repairing a directory.Chris Wilson2013-08-22
| | | | | | | | | | | Report whether the directory still had errors after the first pass of dir.CheckAndFix(), and also whether a file is marked as both Old and Deleted, which means that its block usage is not accounted for anywhere. There's possibly still a bug here where an invalid directory entry that is itself a directory may not result in the parent directory being marked as isModified and written back out afterwards, which may be what's happening to Markus Grunwald (failure to correct the error with "check fix").
* Add a helper in BackupStoreAccounts to get a write lock on an account.Chris Wilson2012-11-18
| | | | | | Use it in two places to simplify code (not in BackupStoreContext yet, because that wants to communicate with HK process as well).
* Remove debugging code.Chris Wilson2011-11-01
|
* Work around lack of unistd.h on MSVC.Chris Wilson2011-03-27
|
* Debugging for Sune Molgaard's issue with non-existent files beingChris Wilson2011-02-23
| | | | | detected as unattached and crashing later in CheckUnattachedObjects().
* Count the number of files and directories in the account during account Chris Wilson2010-08-27
| | | | | | | | | check. Move directory entry checking code into its own method for readability. Reformat long lines for readability.
* Undo mangling by tailorChris Wilson2008-04-04
|
* TailorizationChris Wilson2008-04-04
| | | | | | | | | | | Import of the upstream sources from Repository: http://localhost:8000/ Kind: hg Revision: 7807b7768163f1c2537756abe5416063989cebb1 Original author: tailor@rocio.int.aidworld.org Date: 2008-03-16 19:44:36+00:00
* Replace all remaining use of TRACEx() macros with logging framework.Chris Wilson2008-03-29
| | | | | Remove the old TRACEx macros to catch any remaining uses.
* Convert most printf() and fprintf() calls to use logging frameworkChris Wilson2007-08-02
| | | | | instead. (refs #3)
* Use DIRECTORY_SEPARATOR instead of assuming that it's a forward slashChris Wilson2006-08-31
| | | | | (refs #3)
* Revert to trunkChris Wilson2006-08-31
|
* * mergeChris Wilson2006-07-27
| | | | | | | - This is my current patch queue. I think that all of these are safe to apply. This is just under half of the pending changes in chris/general (the easy half).
* Box Backup 0.09 with a few tweeksBen Summers2005-10-14