summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2019-02-28 22:15:49 -0500
committerAaron M. Ucko <ucko@debian.org>2019-02-28 22:15:49 -0500
commit95f56ab5cbdd1dd2bff66aa8b3fc301f59f12d42 (patch)
tree93e17fdac72faa4a632e78a879f6dfe370247a76
parent1d78b95e64081bd89c7913a49b20f8925646089c (diff)
debian/rules: Take advantage of /usr/share/dpkg/buildflags.mk.
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules6
2 files changed, 4 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index e1f4e4b..be691d5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,9 @@ bsdgames-nonfree (2.17-8) UNRELEASED; urgency=medium
* debian/control:
- Bump debhelper requirement to (>= 11~) accordingly.
- B-D on libncurses-dev, not transitional libncurses5-dev.
+ * debian/rules: Take advantage of /usr/share/dpkg/buildflags.mk.
- -- Aaron M. Ucko <ucko@debian.org> Thu, 28 Feb 2019 22:09:20 -0500
+ -- Aaron M. Ucko <ucko@debian.org> Thu, 28 Feb 2019 22:15:47 -0500
bsdgames-nonfree (2.17-7) unstable; urgency=medium
diff --git a/debian/rules b/debian/rules
index 58265b5..9192ddf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,9 +4,7 @@ DEB_DESTDIR = $(CURDIR)/debian/$(pkg)
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
-CFLAGS := $(shell dpkg-buildflags --get CFLAGS) \
- $(shell dpkg-buildflags --get CPPFLAGS)
-LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
+include /usr/share/dpkg/buildflags.mk
%:
dh $@
@@ -15,7 +13,7 @@ override_dh_auto_clean:
dh_auto_clean -- -f GNUmakefile distclean
override_dh_auto_configure:
- bsd_games_cfg_other_cflags="$(CFLAGS)" \
+ bsd_games_cfg_other_cflags="$(CFLAGS) $(CPPFLAGS)" \
bsd_games_cfg_other_ldflags="$(LDFLAGS)" \
./configure