summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-03-15 12:28:16 +0100
committerDavid Sterba <dsterba@suse.com>2017-03-16 17:02:44 +0100
commit02947f410591dca68ca3b3c5ea4e78d899aedcf1 (patch)
tree9e404c3b8afd9c091dc9300a860bcee48078ec47
parentb5d4b3cef3504b1ca6734ca8fd56b8d6a1c304ac (diff)
btrfs-progs: tests: misc/019, use fssum
The fssum utility is now ready to use, test still passes. Signed-off-by: David Sterba <dsterba@suse.com>
-rw-r--r--Makefile2
-rwxr-xr-xtests/misc-tests/019-receive-clones-on-munted-subvol/test.sh5
2 files changed, 3 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 9e2e6d5c..fdc63c3a 100644
--- a/Makefile
+++ b/Makefile
@@ -276,7 +276,7 @@ test-fsck: btrfs btrfs-image btrfs-corrupt-block mkfs.btrfs
@echo " [TEST] fsck-tests.sh"
$(Q)bash tests/fsck-tests.sh
-test-misc: btrfs btrfs-image btrfs-corrupt-block mkfs.btrfs btrfstune
+test-misc: btrfs btrfs-image btrfs-corrupt-block mkfs.btrfs btrfstune fssum
@echo " [TEST] misc-tests.sh"
$(Q)bash tests/misc-tests.sh
diff --git a/tests/misc-tests/019-receive-clones-on-munted-subvol/test.sh b/tests/misc-tests/019-receive-clones-on-munted-subvol/test.sh
index 5735ecb0..3a572439 100755
--- a/tests/misc-tests/019-receive-clones-on-munted-subvol/test.sh
+++ b/tests/misc-tests/019-receive-clones-on-munted-subvol/test.sh
@@ -5,17 +5,16 @@
# have an entry with the same name that corresponds to different inodes in each
# snapshot.
-# temporary, until the test gets adapted
-FSSUM_PROG=/bin/true
-
source $TOP/tests/common
check_prereq mkfs.btrfs
check_prereq btrfs
+check_prereq fssum
setup_root_helper
prepare_test_dev
+FSSUM_PROG="$TOP/fssum"
srcdir=./send-test-dir
rm -rf "$srcdir"
mkdir -p "$srcdir"