summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikolay Borisov <nborisov@suse.com>2018-03-27 10:45:46 +0300
committerDavid Sterba <dsterba@suse.com>2018-04-24 13:00:10 +0200
commit631bf9f2b9aab3ac84a2646b04dbe7ec303a7ef1 (patch)
tree37a4d6ce86eaa056c3cf825f7fc5da49912ee0b8
parent5a87a95115a0f992ef4d3ef9ad480d8cf3bb27ec (diff)
btrfs-progs: Remove deprecated btrfs-calc-size tool
Its function has been superseded by btrfs inspect-internal tree-stats. Just remove it. Deprecated since 4.8. Issue: #97 Signed-off-by: Nikolay Borisov <nborisov@suse.com> Signed-off-by: David Sterba <dsterba@suse.com>
-rw-r--r--.gitignore2
-rw-r--r--Makefile3
-rw-r--r--btrfs-calc-size.c39
3 files changed, 1 insertions, 43 deletions
diff --git a/.gitignore b/.gitignore
index 06db51f3..144ebb3b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -13,7 +13,6 @@ btrfs.static
btrfs-map-logical
btrfs-fragments
btrfsck
-calc-size
ioctl-test
dir-test
send-test
@@ -29,7 +28,6 @@ btrfs-find-root.static
btrfs-image
btrfs-corrupt-block
btrfs-select-super
-btrfs-calc-size
btrfs-crc
btrfstune
mktables
diff --git a/Makefile b/Makefile
index a63f70ec..0470f2e0 100644
--- a/Makefile
+++ b/Makefile
@@ -215,7 +215,7 @@ progs_install = btrfs mkfs.btrfs btrfs-map-logical btrfs-image \
btrfs-select-super
# other tools, not built by default
-progs_extra = btrfs-fragments btrfs-calc-size
+progs_extra = btrfs-fragments
progs_static = $(foreach p,$(progs),$(p).static)
@@ -228,7 +228,6 @@ endif
btrfs_convert_cflags = -DBTRFSCONVERT_EXT2=$(BTRFSCONVERT_EXT2)
btrfs_convert_cflags += -DBTRFSCONVERT_REISERFS=$(BTRFSCONVERT_REISERFS)
btrfs_fragments_libs = -lgd -lpng -ljpeg -lfreetype
-btrfs_calc_size_objects = cmds-inspect-tree-stats.o
cmds_restore_cflags = -DBTRFSRESTORE_ZSTD=$(BTRFSRESTORE_ZSTD)
CHECKER_FLAGS += $(btrfs_convert_cflags)
diff --git a/btrfs-calc-size.c b/btrfs-calc-size.c
deleted file mode 100644
index d2d68ab2..00000000
--- a/btrfs-calc-size.c
+++ /dev/null
@@ -1,39 +0,0 @@
-/*
- * Copyright (C) 2011 Red Hat. All rights reserved.
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public
- * License v2 as published by the Free Software Foundation.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- * General Public License for more details.
- *
- * You should have received a copy of the GNU General Public
- * License along with this program; if not, write to the
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
- * Boston, MA 021110-1307, USA.
- */
-
-#include "volumes.h"
-#include "utils.h"
-#include "commands.h"
-#include "help.h"
-
-int main(int argc, char **argv)
-{
- int ret;
-
- warning(
-"\nthe tool has been deprecated, please use 'btrfs inspect-internal tree-stats' instead\n");
-
- if (argc > 1 && !strcmp(argv[1], "--help"))
- usage(cmd_inspect_tree_stats_usage);
-
- ret = cmd_inspect_tree_stats(argc, argv);
-
- btrfs_close_all_devices();
-
- return ret;
-}