summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-03-13 16:08:51 +0100
committerDavid Sterba <dsterba@suse.com>2017-03-16 17:02:44 +0100
commit87b971d0cc7c4b72eb45919bc74ca389832e5ea1 (patch)
treecded03c628e0f1a0f0c08b3b61c6bf8fec21079b
parent153d4e6c01b53855d01b5d0c99886ba31b48bad1 (diff)
btrfs-progs: library: distribute sizes.h, fix build
The patch "btrfs-progs: Introduce kernel sizes to cleanup large intermediate number" (a2203246ae483d09) was taken from kernel but not properly ported so the build breaks because the header linux/sizes.h is not exported. The build tests of library do not cover the case when the macro BTRFS_FLAT_INCLUDES is not defined (ie. an external build). Reported-by: Holger Hoffstätte <holger@applied-asynchrony.com> Signed-off-by: David Sterba <dsterba@suse.com>
-rw-r--r--Makefile2
-rw-r--r--ctree.h2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 67fbc483..12f6db79 100644
--- a/Makefile
+++ b/Makefile
@@ -108,7 +108,7 @@ libbtrfs_objects = send-stream.o send-utils.o kernel-lib/rbtree.o btrfs-list.o \
uuid-tree.o utils-lib.o rbtree-utils.o
libbtrfs_headers = send-stream.h send-utils.h send.h kernel-lib/rbtree.h btrfs-list.h \
kernel-lib/crc32c.h kernel-lib/list.h kerncompat.h \
- kernel-lib/radix-tree.h extent-cache.h \
+ kernel-lib/radix-tree.h kernel-lib/sizes.h extent-cache.h \
extent_io.h ioctl.h ctree.h btrfsck.h version.h
convert_objects = convert/main.o convert/common.o convert/source-fs.o \
convert/source-ext2.o
diff --git a/ctree.h b/ctree.h
index 91d55557..13cf3b00 100644
--- a/ctree.h
+++ b/ctree.h
@@ -34,7 +34,7 @@
#include <btrfs/extent-cache.h>
#include <btrfs/extent_io.h>
#include <btrfs/ioctl.h>
-#include <linux/sizes.h>
+#include <btrfs/sizes.h>
#endif /* BTRFS_FLAT_INCLUDES */
struct btrfs_root;