summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGoldwyn Rodrigues <rgoldwyn@gmail.com>2009-01-21 13:22:49 -0500
committerChris Mason <chris.mason@oracle.com>2009-01-21 13:22:49 -0500
commit20da00318d20904a275b0baa44ea430555bc8e91 (patch)
tree691aceceb31cfff2056cadb1cc6530198e125aca
parentfc5a740b1c870f6b7a939d625a5c0d0626b09b36 (diff)
Modify Makefile to include man directory
-rw-r--r--Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 73a875b7..e6a332c9 100644
--- a/Makefile
+++ b/Makefile
@@ -30,7 +30,7 @@ endif
$(CC) $(DEPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c $<
-all: version $(progs)
+all: version $(progs) manpages
version:
bash version.sh
@@ -68,10 +68,17 @@ quick-test: $(objects) quick-test.o
convert: $(objects) convert.o
gcc $(CFLAGS) -o btrfs-convert $(objects) convert.o -lext2fs $(LDFLAGS) $(LIBS)
+manpages:
+ cd man; make
+
+install-man:
+ cd man; make install
+
clean :
rm -f $(progs) cscope.out *.o .*.d btrfs-convert
+ cd man; make clean
-install: $(progs)
+install: $(progs) install-man
$(INSTALL) -m755 -d $(DESTDIR)$(bindir)
$(INSTALL) $(progs) $(DESTDIR)$(bindir)
if [ -e btrfs-convert ]; then $(INSTALL) btrfs-convert $(DESTDIR)$(bindir); fi