summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-08-28 13:33:19 +0200
committerDavid Sterba <dsterba@suse.com>2017-09-08 16:15:05 +0200
commit2e5617c9a6d76b5acd2f04c8567c47803599e843 (patch)
treee98cfb89c2f0bbeebe163b8aec0f76acfdc66da3
parentb8c9c457c125718cdd2a25d876d8dac747f06f01 (diff)
btrfs-progs: build: fix building libbtrfs.so with tsan
Except libbtrfs.so object, all other tools compile fine. The error is: ld: send-stream.o: relocation R_X86_64_PC32 against symbol `stderr@@GLIBC_2.2.5' can not be used when making a shared object; recompile with -fPIC Compiling with -fPIC fixes the problem. Signed-off-by: David Sterba <dsterba@suse.com>
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 3d55203f..3bc9bb40 100644
--- a/Makefile
+++ b/Makefile
@@ -167,7 +167,7 @@ ifneq (,$(findstring asan,$(D)))
endif
ifneq (,$(findstring tsan,$(D)))
- DEBUG_CFLAGS_INTERNAL += -fsanitize=thread -fPIE
+ DEBUG_CFLAGS_INTERNAL += -fsanitize=thread -fPIC
DEBUG_LDFLAGS_INTERNAL += -fsanitize=thread -ltsan -pie
endif