summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Sandeen <sandeen@redhat.com>2014-05-30 11:27:14 -0500
committerDavid Sterba <dsterba@suse.cz>2014-08-22 14:39:33 +0200
commit350bb14bc6b925418e9ecc9852261085d38224df (patch)
tree27a2369722c6795705d2c2f153eb0094a724adfa
parent6c30bee7aa44124892c0c2a7b35a2b5502a28dcf (diff)
btrfs-progs: make pretty Documentation/ build match the rest
This is the most important patch ever. ;) I found this to be less aesthetically pleasing than it was before: [CC] btrfstune.o Making all in Documentation ASCIIDOC btrfs-convert.xml [LD] btrfstune XMLTO btrfs-convert.8 [CC] btrfs-show-super.o GZIP btrfs-convert.8.gz [LD] btrfs-show-super ASCIIDOC btrfs-debug-tree.xml XMLTO btrfs-debug-tree.8 so I shortened the pretty-text to match what we had before. Also, make clean "quiet" like it is in the top dir. Signed-off-by: Eric Sandeen <sandeen@redhat.com> [Changed to ASCII and XMLTO] Signed-off-by: David Sterba <dsterba@suse.cz>
-rw-r--r--Documentation/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Documentation/Makefile b/Documentation/Makefile
index 51f618af..0ff81da3 100644
--- a/Documentation/Makefile
+++ b/Documentation/Makefile
@@ -54,9 +54,10 @@ BTRFS_VERSION = $(shell sed -n 's/.*BTRFS_BUILD_VERSION "Btrfs \(.*\)"/\1/p'\
ifneq ($(findstring $(MAKEFLAGS),s),s)
ifndef V
- QUIET_ASCIIDOC = @echo ' ' ASCIIDOC $@;
- QUIET_XMLTO = @echo ' ' XMLTO $@;
- QUIET_GZIP = @echo ' ' GZIP $@;
+ QUIET_RM = @
+ QUIET_ASCIIDOC = @echo " [ASCII] $@";
+ QUIET_XMLTO = @echo " [XMLTO] $@";
+ QUIET_GZIP = @echo " [GZ] $@";
QUIET_STDERR = 2> /dev/null
QUIET_SUBDIR0 = +@subdir=
QUIET_SUBDIR1 = ;$(NO_SUBDIR) echo ' ' SUBDIR $$subdir; \
@@ -77,7 +78,7 @@ install-man: man
$(LNS) btrfs-check.8.gz $(DESTDIR)$(man8dir)/btrfsck.8.gz
clean:
- $(RM) *.xml *.xml+ *.8 *.8.gz
+ $(QUIET_RM)$(RM) *.xml *.xml+ *.8 *.8.gz
%.8.gz : %.8
$(QUIET_GZIP)$(GZIPCMD) -n -c $< > $@