summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2014-10-30 19:22:32 +0100
committerDavid Sterba <dsterba@suse.cz>2014-11-07 17:52:58 +0100
commit3fba49eab85b9d81a4e619024cc574fe42e4121f (patch)
tree4a533b77e6c26410690b47a064355a36fa9dc03b
parent86be0aeaf638b1b2c0dd453ff30d4dadd96250ef (diff)
btrfs-progs: build, gather utilities that are not built by default
Add them to build test and to clean rules. Signed-off-by: David Sterba <dsterba@suse.cz>
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 126dc593..b597ad8e 100644
--- a/Makefile
+++ b/Makefile
@@ -50,6 +50,9 @@ progs = mkfs.btrfs btrfs-debug-tree btrfsck \
btrfs btrfs-map-logical btrfs-image btrfs-zero-log btrfs-convert \
btrfs-find-root btrfstune btrfs-show-super
+progs_extra = btrfs-corrupt-block btrfs-fragments btrfs-calc-size \
+ btrfs-select-super
+
progs_static = $(foreach p,$(progs),$(p).static)
# external libs required by various binaries; for btrfs-foo,
@@ -254,6 +257,7 @@ test-build:
-$(MAKE) library-test.static
$(MAKE) -j 8 all
-$(MAKE) -j 8 static
+ $(MAKE) -j 8 $(progs_extra)
manpages:
$(Q)$(MAKE) $(MAKEOPTS) -C Documentation
@@ -266,7 +270,8 @@ clean: $(CLEANDIRS)
btrfs-zero-log btrfstune dir-test ioctl-test quick-test send-test btrfsck \
btrfs.static mkfs.btrfs.static btrfs-calc-size \
version.h $(check_defs) \
- $(libs) $(lib_links)
+ $(libs) $(lib_links) \
+ $(progs_extra)
clean-doc:
@echo "Cleaning Documentation"