summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-09-23 21:49:11 +0200
committerDavid Sterba <dsterba@suse.com>2017-09-25 15:18:37 +0200
commit4498f5370750973fb0dde11932f5e7250061cbc4 (patch)
treea83d0a84239986c422ced429cc662edc04d65060
parent628307f5c4de32b282bef30eda7fc034d198c6d4 (diff)
btrfs-progs: build: add missing defines for the C=1 build
Sparse complains that BTRFSCONVERT_EXT2 and _RESIERFS are not defined. The per-target options are missing from the default CFLAGS and only added in the specific rule. Signed-off-by: David Sterba <dsterba@suse.com>
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 922baff7..2e8d932b 100644
--- a/Makefile
+++ b/Makefile
@@ -91,6 +91,7 @@ STATIC_LIBS = $(STATIC_LIBS_BASE)
# don't use FORTIFY with sparse because glibc with FORTIFY can
# generate so many sparse errors that sparse stops parsing,
# which masks real errors that we want to see.
+# Note: additional flags might get added per-target later
CHECKER := sparse
check_defs := .cc-defines.h
CHECKER_FLAGS := -include $(check_defs) -D__CHECKER__ \
@@ -214,6 +215,8 @@ btrfs_show_super_objects = cmds-inspect-dump-super.o
btrfs_calc_size_objects = cmds-inspect-tree-stats.o
cmds_restore_cflags = -DBTRFSRESTORE_ZSTD=$(BTRFSRESTORE_ZSTD)
+CHECKER_FLAGS += $(btrfs_convert_cflags)
+
# collect values of the variables above
standalone_deps = $(foreach dep,$(patsubst %,%_objects,$(subst -,_,$(filter btrfs-%, $(progs)))),$($(dep)))