summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2018-09-11 17:15:04 +0200
committerDavid Sterba <dsterba@suse.com>2018-10-23 14:48:39 +0200
commit678d6c9c0f37ad4006661f111352c99f04aeee71 (patch)
treebadb89fc2743bde3235faad702737bb86e027aed
parent14357b3e340f8e57e922e6c08f5fb621dce77aff (diff)
btrfs-progs: build: remove gzip dependency
The manual pages are not compressed anymore and we can remove gzip from build dependencies and build steps. Signed-off-by: David Sterba <dsterba@suse.com>
-rw-r--r--Documentation/Makefile.in13
-rw-r--r--configure.ac1
2 files changed, 1 insertions, 13 deletions
diff --git a/Documentation/Makefile.in b/Documentation/Makefile.in
index c0467c91..e21d2ad3 100644
--- a/Documentation/Makefile.in
+++ b/Documentation/Makefile.in
@@ -65,7 +65,6 @@ MANPAGE_XSL = manpage-normal.xsl
XMLTO = @XMLTO@
XMLTO_EXTRA =
XMLTO_EXTRA = -m manpage-bold-literal.xsl
-GZIPCMD = @GZIP@
INSTALL = @INSTALL@
RM = @RM@
RMDIR = @RMDIR@
@@ -80,7 +79,6 @@ ifndef V
QUIET_RM = @
QUIET_ASCIIDOC = @echo " [ASCII] $@";
QUIET_XMLTO = @echo " [XMLTO] $@";
- QUIET_GZIP = @echo " [GZ] $@";
endif
endif
@@ -108,16 +106,7 @@ uninstall:
$(RMDIR) -p --ignore-fail-on-non-empty $(DESTDIR)$(man8dir)
clean:
- $(QUIET_RM)$(RM) -f *.xml *.xml+ *.3 *.3.gz *.5 *.5.gz *.8 *.8.gz *.html
-
-%.3.gz : %.3
- $(QUIET_GZIP)$(GZIPCMD) -n -c $< > $@
-
-%.5.gz : %.5
- $(QUIET_GZIP)$(GZIPCMD) -n -c $< > $@
-
-%.8.gz : %.8
- $(QUIET_GZIP)$(GZIPCMD) -n -c $< > $@
+ $(QUIET_RM)$(RM) -f *.xml *.xml+ *.3 *.5 *.8 *.html
%.3 : %.xml
$(QUIET_XMLTO)$(RM) -f $@ && \
diff --git a/configure.ac b/configure.ac
index df02f206..55d540be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,7 +99,6 @@ if test "x$enable_documentation" = xyes; then
AC_MSG_ERROR([cannot find xmlto, cannot build documentation])
fi
- AC_PATH_PROG([GZIP], [gzip], [gzip])
AC_PATH_PROG([MV], [mv], [mv])
AC_PROG_SED
AC_PATH_PROG([ASCIIDOC], [asciidoc])